Did my microSD card die? Can't get past HA load screen and can't view sd card on my PC

The other night I was trying to reconnect my Wink account to my HA setup. Originally I had it working fine on a PC running HA without SSL. A month ago I switched to a Raspberry Pi 3 running Hass.io. I spent a lot of time getting Let’s Encrypt and Duck DNS configured properly.

So the other night I was trying to re-authenticate Wink and I had read multiple threads where people said to use the local ip instead of the https://domain.duckdns.org. I tried that but HA Wink config kept telling me to use the duckdns address. So I tried to disable it by commenting out 2 lines in my HA config file, the ones under http: that had to do with SSL.

Ever since then I cannot use or even see that my Pi3 with Hassio even works. I take the microSD care out and put into a card reader on my PC and it doesn’t detect. It makes me worried that I can’t even salvage my .yaml files and configs and that I’m going to lose a month’s worth of progress.

Does anyone have any idea or tips I can try? I really want to salvage some stuff off my sdcard. In the future I am thinking off making my pi bootable off of usb instead of microsd.

Since it’s Hass.io, I can’t SSH into the Pi and Samba isn’t working. Using both the local ip address and the duckdns ip address to load the webscreen and no luck. It just sits at the splash screen never even offering me the login fields.

Please help! Or am I SOL? Thank you

1 Like