Difference between Deconz and ZHA (conbee stick)

Hi, i am using deconz for now, it works wit events ID
but seems now the ZHA component is native supported it seems? (according on the github site ) any1 tried it yet? do we still need to work with automations and event id’s? for example an ikea remote switch? or how will those button pressed be handled in HA? since it has about 10 buttons on it

second question :
what do i need fo use for radio type? in documentaton below
radio_type (String)(Optional)One of ezsp or xbee .

but both are wrong i think for the deconz conbee stick ?

It will be a part of 86. I’m gonna play s pund with it on my second conbee. But I still think deconz is more mature than zha.

ah ok, thnx for info, have to wait fot it then :slight_smile:

I am using deconz+raspbee now, but it would be great to have some feedback from somebody who tried the zha component with conbee/raspbee.

I’ve been hesitant to switch as well, even though ZHA will probably be better for the future (and I’m not a fan of deconz in general). I’m afraid this way we’ll all be waiting on each other to take the first step :smiley:

Why not a fan of deconz?

1 Like

I think it is a bit of a clunky solution so far (as evidenced by all the systemd services it starts for instance). In general it doesn’t seem optimized to be controlled from a headless server, I often see nice screenshots of the network you apparently can get if running on a desktop, but none of that is available to me.
More in general I’m not a fan of the interface, phoscon or otherwise.

I’m happy with the usb-stick itself though :smiley:

Yes, I’m not a great fan of the deConz option - seems too heavyweight, but my attempts to get a Conbee going with ZHA have completely failed so far. And it’s not just that it doesn’t work: it kills HA at the point where it loads the configuration, so there’s no GUI, nothing else working, until I go back, take it out of the configuration, and reboot.

On the couple of occasions I’ve tried this, I have:

  • Disabled deConz, so it’s not talking to the Conbee
  • Removed references to it and its devices from the .storage files
  • Rebooted and made sure its container really isn’t running
  • Set up ZHA carefully with the right device and specifying the radio_type.

But still no luck. I’d be interested to know if anyone has the ZHA+Conbee combination actually working?

Haven’t gotten zha working with my raspbee shield either, previously had it running with deconz but the zha service doesn’t seem to start at all…

I have my Conbee running, integrated with no issue at all. I put in the port and chose deconz for the protocol on the integrations page. Be sure you have the latest firmware by looking in Phoscon. Also Phoscon may not be presenting the most current version available to flash. I am running firmware 0x26300500 and it’s been fine but had to flash manually.
Download firmware at https://www.dresden-elektronik.de/rpi/deconz-firmware/deCONZ_Rpi_0x26230500.bin.GCF and flash it with GCFFlasher -d 0 -f deCONZ_Rpi_0x26300500.bin.GCF command. You can run GCFFlasher -l to see what devices are available for -d option. The Bootloader Flash Tool is here https://www.dresden-elektronik.de/funktechnik/service/download/driver/?L=1

My experience to date which is minimal is my Samsung Motion Sensors did not work in deCONZ but work with the native integration and my Cree Bulbs which did work now do not. There have been some updates and I have not tried the Cree again yet I have them connected to my OSRAM Hub. I have found no device support list for the native ZHA so it’s all a try and see at this time.

Shouldn’t make a difference but probably should have added…
Using Intel NUC, Ubuntu 18.04, Docker and HA 0.88.2

Another edit… should have added I did the flashing on my Windows PC.

Thanks a lot for this. Just want to point out a small typo that cause me a little confusion:
There are different firmwares in your link / the upgrade command (0x26230500 / 0x26300500). Since they are really similar I didn’t see it at first.

Anyway - thanks a lot. The upgrade procedure was really easy when you knew how to do it :slight_smile:

The developers now have us all back on firmware 262F0500 due to issues with zigpy-deconz.

Apparently not all has been worked out for using deCONZ devices in HA.

This link is to the latest open issue…

@MarVin have you tried ZHA with your cree bulbs recently?

I don’t use cree bulbs but I’m wondering about the general state of compatibility with ZHA. Currently using deconz and considering a move to ZHA since it is the default integrated ZigBee solution.

this thread is currently the top home-assistant.io result for zha deconz

Try it and report back :slight_smile:

I also do not want to run deCONZ it’s just something else to maintain. Apparently other than the Cree Connected Conbee and native ZHA have been working well. If you look at GitHub - zigpy/zigpy-deconz: A library which communicates with Deconz radios for zigpy there are no real open issues. Not sure what you have for entities but do some searching in the forums I bet you don’t find a lot. It may be there are not many running Conbee with native ZHA though. If you are going to switch I would to a full system snapshot so you can quickly move back if you need to.

After extensive work with the developers apparently Conbee with Native ZHA and Cree Connected just don’t get along and we are not sure why. Seems to be some sort of timing issue. Using deCONZ with the Conbee the Cree Connected seem to work just fine.

My issue is Samjin (Samsung) motion sensors are not working yet on deCONZ or on OSRAM Lightify but do work well with Conbee and native ZHA. I have all my lights on OSRAM Lightify and the Samjins on Conbee Native. I built a Zigbee sniffer and am going to get another Cree to test with and hopefully working with the developers will resolve this for the future.

Hi, is still ZHA behind deCONZ (with Conbee I)?

how do you update firmware on conbee stick if running zha instead of deconz?

I just switched from ZHA to deconz. I was having issues where lights were not responsive, and a restart of Home Assistant would fix the problem. Deconz has been flawless so far.

1 Like

Why zha in stead of deconz?
I’m planning to het raspberry and only run deconz on it with a conbee connected…
That way, i can have home assistant on a separate rpi or nuc (don’t know yet). And if there is a problem with ha, i can reboot it, without affecting the zigbee network…