Different Icons not showing on older iPads

I have two iPads that run iOS 10 on the wall in the house. I have set some different icons for the switches so they appear to be lightbulbs. On my computer, this is what they look like which is correct:
Screen Shot 2020-12-20 at 12.49.27 PM

I’ve downloaded the HA app on the iPads but no matter what I do, it always shows the default icons for the switches:

Any idea what is causing this to happen? I tried the HA App and I also tried Safari and both do the same thing.

I was able to see that I am able to edit an entity directly and change an icon there. Then it changes on the iPads. While that is better than nothing, it tells me that the iPads are indeed capable of showing the icons and that it must be a bug of some kind that when I change the domain for the switch with a specific icon, that they aren’t changed on the iPads.

This is looking more and more like a bug with older iPads for some reason. I think that people will be using older iPads all the time to be wall mounted.

Is there anywhere else that I can go to report the issue? I think it should be fixed. Since it is just a different image being displayed, I think it should work on older iPads as well.

I was able to figure out that I can change the icons if I set them in the entity themselves, but any changes made in the customization domain or anything where there is a template and any logic like:

if (state === "on) return 'mdi:lightbulb'

then it won’t work on the older iPads. :frowning:


I had this start happening today. I updated I believe from an October 2021 release of Home Assistant to 2022.6.2. I then updated HACS, custom-ui, and many other components.

The iPad is an original iPad Air running iOS 12.5.5 (Not new enough for iPad OS). It was working fine prior, but now it just shows default icons and colors for anything that is set using template or to follow the state of the entity. This happens using the Home Assistant app as well as Safari. All other devices and browsers seem to work ok still.

Here is some code:

        icon: >
          if (state == 'unlocked') return 'mdi:lock-open-variant';
          if (state == 'locked') return 'mdi:lock-outline';
          return 'mdi:lock-open-alert-outline';
        icon_color: >
          if (state == 'unlocked') return 'red';
          if (state == 'locked') return 'green';
          return 'red'; 
        icon: >
          if (state == 'off') return 'mdi:lock-outline';
          return 'mdi:lock-open-variant';
        icon_color: >
          if (state == 'off') return 'green';
          return 'red'; 

On the newer iPhone that is working:

On the older iPad, default icons and colors: