Difficulty including new Zwave devices with Z-wave JS UI

Hi All -

Moving my system over from HomeSeer to HA.

I actually went through my z-wave devices once using the “official” Zwave JS implementation. Overall that went pretty smooth (some issues adding devices as my network got larger). Learned more about Zwave JS UI and decided at that point that this would serve me better in the long term.

Decided to just start over from scratch - started a fresh install of HS, and reset my Zooz 800 series LR controller to factory settings (erased the z-wave network).

Followed instructions to install Zwave JS UI as the Zwave controller and it appears to be correctly installed - it recognizes the Zooz controller, etc.

Adding a zwave device however is not going well. I’m trying to add with security (s2) - went fine when using the official zwave interface. With JS UI, it never asks me for the PIN code. It adds the device, but all the information is incomplete and there is no security - as below:

If I reinterview it will sometimes pick up more information, but not always.

I’m really at a loss here as to how to proceed. This worked pretty well with the “official” Zwave implementation but seemingly isn’t with the JS UI.

Any help appreciated, thanks!


*Distance from the stick to the switch is about 2 feet. I have them very close.
*I am using a USB extension cord as suggested on many other threads.

Was able to get 1 of 5 switches successfully enrolled.

Inclusion often times out, even after previously excluding and factory resetting each individual switch.

Occasionally i’m getting the message on inclusion: “Node X added with security:none. Expected message was not received within the corresponding timeout.”

You aren’t alone! I just finished migrating bunch of devices from SmartThings to HA (both Zigbee2MQTT and Zwave JS UI) and yes, it’s like that. You have to reset devices many times hoping that HA will detect them, until it eventually does. The worst was HomeSeer switches and Dimmers - took dozens of resets to get them discovered.

Eventually I added the switches more or less reliably using this process:

  1. Reset the device (in my case - turn on, 3 taps up, 3 taps down lights blink as confirmation)
  2. Turn it off
  3. Reboot HA. You have to actually reboot the host machine and not just “Restart HA” - probably something to do with USB stick
  4. When HA is fully back, go to Zwave devices, start discovery
  5. Turn on the switch

This is crazy. I have to be doing something wrong here.

I’m tempted to go back to the standard Z-Wave integration. Though when I did that and tried to migrate over to JS UI, there were a whole host of errors…

We have to be doing something wrong, it can’t be this wonky.

Unfortunately that goes beyond my expertise. I don’t have that issue. To add or remove Zwave devices I use both the Zwave feature that came with my system (or was added initially) or the Zwave JS UI.
From time to time my HA stops recognizing Zwave. when that happens I power cycle my Yellow Box and that resolves the problem.

Yeah that doesn’t seem to be the problem here…

Very frustrating…

Hi, Did you ever solve your issue ? I might be facing the same problem. I have installed Zwave JS UI on a new install with a Zooz 800 series stick, I successfully added 10x old fibaro sensor, some new zooz serie 800 sensor, range extender, some switches (15 devices total) without issues at first.
But since then I cannot add or remove any device, I tried Shelly (serie 800), Fibaro (zwave+) and nothing shows up in the log.
I powered cycle HA, the stick multiple times. The only device it seems to recognize at inclusion now is the zooz 800 serie XS sensor but I cannot add the PIN and I got the same message as yours “Expected message was not received within the corresponding timeout”.
I updated this morning to the latest version of Z-wave JS UI but it didn’t solve the problem.
Like you said, there must be something wrong either with the stick or in the configuration.
Is anyone else having issue with the Zooz Serie 800 stick (ZST39 LR) ?
The strangest thing is all the devices that were included before this issue send their state/value normally.

Try opening the Z-Wave JS UI page in an incognito tab or clearing the cache. I’ve had issues where stuff was not showing and this fixed it for me.