Directv media play error

I’m not sure what I’m doing wrong but I’m getting the below error trying to get the new Directv media player component working.

16-08-02 12:26:29 homeassistant.components.media_player: Error while setting up platform directv
Traceback (most recent call last):
File “/usr/local/lib/python3.4/dist-packages/homeassistant/helpers/”, line 98, in _setup_platform
File “/usr/local/lib/python3.4/dist-packages/homeassistant/components/media_player/”, line 44, in setup_platform
File “/usr/local/lib/python3.4/dist-packages/homeassistant/components/media_player/”, line 60, in init = DIRECTV(host, port)
File “/var/opt/homeassistant/deps/”, line 33, in init
File “/var/opt/homeassistant/deps/”, line 73, in get_tuned = self._combine_channel(jResp[‘major’],jResp[‘minor’])
KeyError: ‘major’

It helps if you give as much information as possible on your setup, such as the configuration.yaml code you have for the directv media player platform

For the configuration file I just have it as

- platform: directv

The autodiscovery sees the IP address but never fully loads due o the error message.

I know this is a bit old, but I fixed this by manually specifying the IP address and the port (8080 in my case)

I’ve had to reformat the SD card and did t he all in one installer and it seems I’m having the same error message. I’ve tried adding the IP address and port and nothing. Not sure what I’m doing wrong.

any response to this. I have 3 Directv HDR boxes, a Geni box, and 3 Geni Clients. HA is finding two of the HDR boxes, but not the third. It isn’t finding any of the Geni items. I tried specifying the missing HDR box in the configuration.yaml file as follows

  • platform: directv
    host: aaa.bbb.ccc.ddd
    port: 8080
    name: office

and it’s not finding it.