Disable Google Cast Discovery

Hi all,

since updating to 0.95.0b1 i’m constantly getting a floating information about a discovered Google Cast, even though i ignored auto-discovery of google_cast in my configuration.
Anyone else facing this problem?
How can i solve it?



1 Like

I have the same problem. Also added the ignore line but hassio keeps find the Google cast.

1 Like

I’m getting the exact same thing, very annoying, I assume it’s a bug, as 0.94.x didn’t do this.

I’ll set up an issue on GitHub if there’s not one already?

EDIT: There is one already, add your info in here if you haven’t done so already :slight_smile:


Same here. Started with 0.95

I’ve gone back to 0.94, it seems to be fixed on 0.94, so I can say that 0.95 caused this problem for me.

In the release notes for 0.95.0 here:

there is this:

Could this be causing the issues maybe?

Can I run 0.95 with the 0.94 pychromecast to test?

Same here. Started on 0.95. Now on 0.96.4.
Annoying, but not a good enough reason to go back to 0.94.

Anyone figured out away to get rid of this? i have it marked to be ignored in discovery yet it still notifies me on bootup

what HA version are you running?

v0.98 but it was happening with 0.97 as well. But I think it started on 0.95 as well

Same here. Is there a way to ask for the documentation on “discovery” to be updated, at least?

Do you know what it should be to disable it?

I’ve unplugged my chromecast for now, short of putting on a VLAN and blocking it at a network level I don’t really see a solution for this.

You can just disable the Discover component. That makes it go away as well, but now new things won’t be discovered :slight_smile:

How to disable discovery component?

comment out “discovery” in your config