Disable uPnP Discovery?


#1

How do I exclude uPnP from Discovery? The persistent notification is getting irritating.


#2
discovery:
  ignore:
    - upnp

#3

Starting with HA 0.85.0, in my setup the UPNP component is discovered on start. Like tc23, I’d like to disable that. I already tried to ignore “upnp”, but unfortunately, that doesn’t work:

Invalid config for [discovery]: value is not allowed @ data['discovery']['ignore'][0]. Got 'upnp'. (See /config/configuration.yaml, line 55). Please check the docs at https://home-assistant.io/components/discovery/

#4

Ditto, tried that ignore, but got the same error. Really don’t want to be forced into enabling a component to make a notification go away :confused: . And I would disable at the router level, but I believe that messes with things like Chromecast (RIP Chromecast Audio)


#5

It is igd.

discovery:
  ignore:
    - igd

#6

Awesome! I will have that a try. Thank you!!


#7

Works for me :slight_smile: Thank you!