Disable "Which card would you like to add to your "Home" view?"

So I have this tiny issue, every time I open/refresh HomeAssistant I get this annoying prompt… how do I disable it?!

It’s driving me nuts and actually on mobiles when this thing pops up half my cards disappear for some odd reason, once I clear up the cache it works fine. But when I reopen HomeAssistant again it gets all screwed up then I have to keep clearing up the cache of my browser on mobiles.

Any hints at what is going on? I am absolutely clueless, it was working fine and now this keeps happening. There’s 0 errors.
It loads fine when I clear up cache until that prompts shows up. If there’s no prompt then it loads correctly; after the prompt shows up 7 out of 10 cards disappear and won’t reload no matter how many times I refresh my browser (same behavior on Chrome and Brave). The only way to bring the cards back is by clearing the browser cache.


This recently started happening to me too when I upgraded my HACS integrations and plugins. I have the following installed:

BWAlarm (ak74 editions)
Entity Controller

Custom Header
Dual Thermostat
Fan Control Entity Row

Do you happen to have any of these installed? I’d like to try and find out which one is causing this problem, so I can take it out back and shoot it.

Basically what broke it was an update of one of the plugins. From these I was only using card tools/mod and fold entity row, vertical stack in card, and others. Even rolling back was giving me issues.
But this definitely happened after updating some of these though HACS.

I had to update HACS manually to version 16.2 (because mine was a really old version so I couldn’t update it via UI). Then update HACS all the way to the latest one; then update all the HACS components/plugins and revise my lovelace.yaml as I had a lot of unnecessary code.

I never touch my yaml code nowadays, so this was the perfect excuse to update all my components and clean my code, that fixed it for me.

Same as always if it works, don’t touch it and don’t update it unless you can spend some time in amending it.

Also having this issue now after updating hacs. I have quite a lot of components installed. How to find the rootcause of this ?

I am having the same problem now. any hints would be much appreciated

Updating your custom cards or getting rid of cards that are no longer being supported gets rid of this issue.

It was an old version of card-tools causing this. Update and you should be fine. In my case I have secondary-info-row which requires card-tools still otherwise I would remove it.

1 Like

Updating card-tools fixed it thank you so much

1 Like

Where can I find the card-tools?

It’s a custom card

I apologies, but I can not find card-tools, please help

it’s in Configuration (side bar), dashboard and ressources. Remove or update it