Disableing SensorWorker

How can I completely disable the HomeAssistant’s SensorWorker background service?
I’ve disabled all the Sensors in the app’s Settings. I’ve also disabled “Allow background activity” and “Allow background data usage” for the HomeAssistant app. However I’m still getting getting the “Updating Sensors” notification.

I know I can hide the notification, but I want to get rid of HA’s background activity completely.

Did you disable location tracking as well?

Turn off the notification channel

Edit: once you disable all sensors the worker still checks that all sensors are disabled on a periodic basis so you just need to turn off it’s channel at that point.

1 Like