Disabling 'Automatically close connection' does nothing

Samsung Tab A8 (SM-X200) — Android 11
HA Android companion (2022.6.0)

Lovelace dashboard reloads after 5+ minutes on device wake up. If I wake before 5 minutes, the dashboard does not reload.

try making sure the app has permissions to run in the background on the tablet

Thanks for the response — permissions are applied appropriately. I have no issue with my Fire tablet.

This could potentially be a Samsung Android 11/12 issue. I would be interested to know if anyone with a Samsung tablet/phone has this working appropriately. Maybe there’s a workaround I may be missing.

Some research:

Sorry to bump.

Would love to know if anyone has any insights on this? Tab A8 is otherwise perfect for Home Assistant if this was a non-issue.

Not unique to Samsung, same issue on the Lenovo M10 3rd generation running Android 12. All battery optimizations have been disabled, and HA has unrestricted access to battery usage.

Again, Fire HD 10 tablet (running Android 9) does not have this issue.