Disastrous update to 2024.6.0

Yesterday (late evening) I updated from 2024.5.5 to the latest 2024.6.0 somehow already having the feeling in the back of my mind that something would go wrong, and in fact it did go wrong, very wrong.

The update page stayed there for a long time, before I noticed that the update was not restarting HA.
Since the installation runs in a docker container (curse), and I am a noob using it, I started searching online for solutions.

  • I restarted the whole machine - no luck
  • Tried to find some logs - no luck finding how to access them (by now midnight and tiredness already approaching)
    Then in a tiredness infused moment of genius, I decide to type what seems like an innocent command but in reality some sadists at docker decided that docker run in reality translates to docker f’up your container.

The result is that it pulled the latest image (which it should already had at this point) and now I have the onboarding page greeting me instead of what I have worked on for the past three years.

Moment of panic, do I have a backup?
Turns out I do, but more strangely, the samba network share, still shows the full HA folder structure config files, and backups of my good installation.

What is weird is that now the add-on page no longer exists in the settings page of HA.

The question now is, what do I do now?

  • Is there a way to restore the container to what it was before?
  • Should I remove all docker containers and recreate them again?
  • Should I forget about docker completely and just run HAOS in a VM like VirtualBox? (when I installed HA this option was not available)
  • Other?

Keep in mind that I want to restore the backup from the previous installation as much as possible.

I think I have the same, but with VM.

EDIT: I see that after a very long startup, I have the web UI. Components are still coming up - taking minutes to start, though.

sorry I’m not sure I understand.
As in the same, do you mean you are experiencing the same issue, but with HAOS in the VM?
Or are you recommending using a VM?

Thanks for your edit, It is clear now.

From that it sounds like you currently use HAOS. You only get add-ons with HAOS (and Supervised, but hopefully you didn’t make that mistake).

Grab those. Grab them now.

That really depends on what your actual install method is, and what you did wrong.

If you’re using HAOS and used docker run then you probably created a new HA container alongside the actual one.

It is/was a supervised installation, as that was the only option that I could use at the time.

I have backed up all of the data I have from the old installation. I was very quick to do that once I saw the files.

It has been a three days odyssey, I ended up with a new Debian installation and Virtualbox VM. What is annoying is that the installation documentation is incomplete, so I had to fill those gaps myself, but in the end I manage to get to the restore backup page.
Turns out that the backup is useless as when I restore it, the system doesn’t boot anymore like it did just after the previous disastrous update.

The logs just states [supervisor.homeassistant.core] Home Assistant has crashed! and nothing else.

Is there a way to get a bit more information from the logs?

I had to recover from the 2024.6.0 crash as well. Just posting this summary here in case someone else might find it useful.

I have four HA Supervised installations, all on RPi4 8GB Ubuntu 20.04.6, all identical. (Yes they are unsupported installations; no lectures necessary).

Two of the four on rare occasions stop responding (likely the pwr supply issue but not conclusive yet). When they do, cycling pwr brings them back up. They were all running 2024.5.5.

On 6/6 one of the four dropped out so I cycled pwr. It did not come back up, but I could still SSH into the RPI. Inspected home-assistant.log.fault and saw at the top the “Fatal Python error: bus error” message.

The issue was reported here: Current Docker RC tag won't boot on RaspberryPi 4 8Gb, Fatal Python error: Bus error · Issue #118507 · home-assistant/core · GitHub and fixed with 2024:6.1.

Even though I had not expressly kicked off a core update to 2024.6.0, the Supervisor had done that in the background as part of its repair process.

But since this HA installation was now dead in the water, the question was how to upgrade to 2024.6.1 via SSH. After confirming I had sufficient backups, I was able to do this at the linux command line by using HA’s command line interface.


sudo ha core update

did its thing, and then responded with

Error: unknown error, see supervisor


sudo ha core info

now showed this:

version: 2024.6.1
version_latest: 2024.6.1

And then with:

sudo ha core start

the response was:

Command completed successfully

and my HA installation was back to normal.

In retrospect I believe that I could also have done:

sudo ha supervisor repair

to have the Supervisor do the upgrade for me. Either way the HA command line interface was the solution. Very useful tool; great job devs!