DISCONTINUED HA Client - native Android client for Home Assistant

Nice! Really fast loading! Would love the default home also so i wouldn’t need to add everything in to the groups.

1 Like

Thanks for letting us try your project. Looks very promising.

I am having troubles while trying to connect to my Home Assistant.
I usually access by going to “https://myurl.duckdns.org” in my browser, but when I try to connect using your client I get a “Connection timeout (Code: 1)” error.

I have enabled the HTTPS switch and wrote the URL without “https://”. I have tried with ports 8123, 80 and 443. So far the only one that seems to do something is 443.

This is my configuration:

As another user said, I tried changing my token and I get an “Incorrect token” error, so I guess it’s connecting.

Any ideas?

Check in router settings, which external port you are forwarding to internal 8123. Maybe you have used different one?

1 Like

Just published a new version 0.1.1-alpha. It will appear in Google Play in one hour or so.

  1. It will skip entities and views that causing parsing errors
  2. It has log viewer available from menu -> Log. It holds last 50 messages. To copy log somewhere just open “Log” from menu, long tap on any text in log, “Select all”, “Copy”.
1 Like

Already available in my store. :+1:

1 Like

Do you mind if I share this in the HA Discord

I have several parsing errors. How are you going to work out what’s causing the errors? Do you need anything from us?

I was having this problem, force quit the app and then it started working.

I’m forwarding 443. Just checked again to make sure.

I tried, but no luck :frowning:
Thanks for the tip

So port is good. Did you try using api password instead of token?

Working now, the only problem Is that my default View got errors

You could try implement notifications into the app as well. Crewski has a notification app that uses firebase so theres no reason you couldn’t add it to this app as well Android actionable notifications

1 Like

Installed and working ok.
One issue I have is my Cover entity is not clickable as is my Lock.
There is no way to interact with them.

I can’t seem to get it to work. Does it work with “invalid” or self signed certificates? Whenever I use Python Requests I have to “allow invalid certs”

Share please

Please create an issue on GitHub with this screenshot and let’s sort it out

I’m already saw this project and definitely HA Client need this functionality, but first of all we need to make it more stable.

1 Like

The only entities with controlling support for now is switches, lights, automation, scripts and scenes.

Unfortunately now it is not working with invalid certificates. Please, report this issue here, maybe it is possible to fix this.