Discovery not working

Next problem!
I just bought a Nexa outdoor switch to control my chrismas light but now I have problem to add the switch to HA.
I have following code.

# Setup rfxtrx device, 433MHz
  device: /dev/serial/by-id/usb-RFXCOM_RFXtrx433_A11FLXWX-if00-port0
  debug: True
  dummy: False
  # 433MHz switches
  - platform: rfxtrx
    automatic_add: True

Have checkt my RFXtrx and it recieve message from the new switch.
But the new switch don’t show up in the HA frontend.
Do I need to do something more?

You never got any of it to show up in dev tools…so you are expecting this one to work?

Not really :face_with_raised_eyebrow:
Do you have any suggestions what I should do?
At least I know that the RFXtrx antenna is working.

This problem started when I changed plattform for the Hassio. From RaspberryPi to Docker on Ubuntu.
Could it have something to do with the Docker setup?

Did you disable uninstall modemmanager on Ubuntu. I know this is required for ZigBee stick to work on Ubuntu/HA. It might be required for your rtxrfx stick as well.

francisp, no I haven’t disable modemmanager.
I don’t know what it is.
How can I disable it or check it?

From the documentation :

The modemmanager package will interfere with any Z-Wave or Zigbee stick and should be removed or disabled. Failure to do so will result in random failures of those integrations. For example you can disable with sudo systemctl disable ModemManager and remove with sudo apt-get purge modemmanager

Thank you, francisp. I will try this and see it make any different.

But earlier in this thread flamingm0e wrote this:

There is no device to include. --net=host passes through the host networking.


> I have just discovered that the Discovery dosen’t work.

Nothing is being discovered? Because discovery works on a default setup like you have provided.

Is “–net=host” the same as ModemManager or?

No it isn’t. modemmanager does not play nice with usb serial devices, this has nothing to do with networking.

The Modemmanager seems to be the problem.
Yesterday evening I added on new 433MHz wall plug.
I will try to add some more today.

Hi David, I have see many of your responses on the community and think you can definitely help me out :slight_smile: please can you look at : Auto discovery not working on ubuntu 18.04 installed on laptop

Thank you.