Display not entirely filled using ILI9341 display (touch) and esp32-s3-wroom-1

Hi all!
I am trying to get esphome to work with an ili9341 display, but it’s nog fully using the display.

The touch seems to working fine for the entire screen.

I’ve tried many different configuration, but nothing seems to help. I believe the pins are ok, since I see a part of the screen as expected (red line and timestamp).

This is the display I’m using (it’s been tested by the company and should be working): https://www.tinytronics.nl/nl/displays/tft/2.8-inch-tft-display-240*320-pixels-met-touchscreen-spi-ili9341

This is the config I’m currently using:

  - platform: ili9xxx
    model: ILI9341
    cs_pin: 10
    dc_pin: 6
    data_rate: 80Mhz
    spi_mode: MODE0
    color_order: bgr
      height: 320
      width: 240
    update_interval: 5s
    reset_pin: 5
    rotation: 0
    id: tft_ha
    lambda: |-
      it.rectangle(0,  0, it.get_width(), it.get_height(), id(my_red));
      it.strftime(it.get_width(), 0, id(arial), TextAlign::TOP_RIGHT, "%H:%M", id(esptime).now());

Does anyone experienced and solved this or know how to find the issue?
Thanks in advance!

Try height: 240, width:320

Thanks for the tip, but that is making it worse. The time digits aren’t visible anymore, just random pixels.

As far I see on many pictures, like China Low Price 2.8 Inch ILI9341 240x320 SPI TFT LCD Display Touch Panel - Quotation - GNS COMPONENTS - screen active zone is NOT the same as glass. IMHO it used on full in Your test.

see that 00:00…

Oh, I see - looks only top line is working.
First guess - device is broken, attach & check another one.

My experience with our Chinese brothers :slight_smile: - do not buy one device, 2 at minumum, better 3.
Then have a some chance one is working.

Thanks @Masterzz. Indeed the top is working, surprisingly I also have a working blue line halfway right now. I bought it online here in NL, the first was broken and they tested another one and sent it to me. So this one should work. I also see that the grey part does something, it’s different then just white backlight, more like grey lines.

Update, I’ve replaced the dupont wires with direct attached dupont wires without de breadboard and now it works just fine. I guess it’s just a faulty wire!