DLNA Media Server - Unable to play all tracks for an album or artist


I have added the DLNA Media Server integration (pointing to my Emby server) and I can successfully browse my library and play single items (movies or songs) on my ChromeCasts or Smart Speakers.

However, when I try to play an entire album, the Smart Speaker does do the “pling” sound, but noting is played. The screen just stays as follows:

Any idea how to investigate/fix this?

Aside my own same question and another one…this is the 3rd one, so I guess it does not exist (yet). HA is of course not meant as full fledged media player so not too disappointed…still … would be nice though

Ah, must have used other search criteria because I did not find your question.

Do you have the same issue though? That the button indicated in Red does not seem to work? Looks like it is intended to work and play an entire album, but it’s just broken.

I do not even have this button but I only play on Receiver or TV…tried now with a google mini but also no button…did you implement anything particular to have this button shown?

I’m also trying this out and found that the PLAY button just plays the record image (it shows an image that is) and not the full album audio. Selecting the separate tracks will play these.
If anyone found out how to play the full album would like to know.

1 Like

Again/still no button for me…I do have png or jpg in my folders but no button shown (neither the file related)…so possibly it depends on the DLNA server, I use Syno Media Server.

I can browse my folders shared by DLNA server but no playing of .mp3 or .mp4. Just the rotating circle when I hit play.

That seems to mean that the player does not accept the object. I could play (almost) all my DLNA sourced/server objects on the browser…on other player…not that easy and may be due to connection issues, e.g. my Chromecast does not play anything from HA, but accepts all from my laptop

Yes, the DLNA seems a bit strict or something. I can browse all Folders but if I browse by Artist it bombs out (DLNA server missing) and I need to reload the Integration to make it work again. There are a lot of Artists in the database so that might be a reason.

Just to keep this thread alive. When selecting a whole album or playlist, the Media Browser just selects the album art:

    - {}
    - media_content_type: app
      media_content_id: media-source://dlna_dms
    - media_content_type: image/jpeg
      media_content_id: >-
    - media_content_type: image/jpeg
      media_content_id: >-
    - media_content_type: image/jpeg
      media_content_id: >-

1 Like

This is still an issue.

Also, no support from m3u playlists on DLNA

I am also still seeing this an an issue. It would be great if this worked.

I can’t find an issue in github under dlna_dms. Was there an issue created?