DNS Problem

I have lots of problems in my install which was running fine until very recently - Basically I have numerous entities saying “entity not available”.
Having done some research and believe the issue is a DNS one, though I have not changed anything.
Can someone please advise if there is a way of resolving this - please keep steps simple - I’m on a Hassio install and a Noob at all this.
Appreciate any help.

Ive tried the following:

  • hassio dns options --servers dns:// (also tried
  • hassio dns restart`

I continue to get:

19-12-12 14:02:39 WARNING (MainThread) [hassio.tasks] Watchdog found a problem with CoreDNS plugin!
19-12-12 14:02:39 WARNING (MainThread) [hassio.tasks] CoreDNS plugin is in fails state / Reset config

Thanks everyone for your help.

That’s not necessarily a DNS problem. What entities are these?

Thanks for response. I’ve done a whole new reinstall which is fine for the moment. HA is a really tough path. I’ve tried it a handful of times over past couple of years, yes I keep coming back to it because it has SO much potential but constantly silly things happen you end up at a dead end and there’s no support presumably because your problem, to the community, appears so trivial.
I also use Smartthings which actually is really good and very cheap (no subscription fee).
If the powers that be want to get real traction on HA they need to engage .
Yes probably HA is right for many but we all need to start somewhere.
A simple like how do you reboot it? Never gets a straight answer, as do many others. Maybe some kind of interactive workshops would be helpful.
I’ll battle on ,
Just my tuppence worth…

What is the output of hassio dns info?

not the OP… but mine is

hasscore-ssh:~# hassio dns info
host: ***.**.**.*
latest_version: "1"
- dns://
- dns://
- dns://2600:1700:1f60:4f00::1
- dns://
- dns://
version: "1"

Or most likely no one who knew the answer saw your question.

Well it depends on what you mean by reboot… What are you wanting to achieve or why do you want to reboot? To reboot the whole thing there is an option on the hass.io side panel on the system tab - Reboot Host although you should not ever need to do that. To just restart the Hass.io system, there is an option to restart the server under server control… This is normally the option you would use…

reformatted / reimaged my SD and it went away.

Thanks for your responses.
My issue with restart was merely an example of frustration (LOVE HATE relationship) I have towards HA.
You say a full restart is not normally required however I have found that it is the only way of newly added resources (in this case MQTT additions or changes to config.yaml being recognized. Furthermore the only successful boot I have found is pulling the power! And yes I realise the consequences.
I have tried all documented restarts including the Hassio reboot but strangely during this process I can still maintain a SSH connection, how could that be a reboot?
Furthermore in four or more attempted rebuilds
(over a couple of years) from my regularly created snapshots, I have never successfully managed a restore.
My mail was sent out of frustration. I appreciate this is a home brew system and far from a commercial product but the simple things seem so problematic, documentation is appailing.
If someone took on regularly UPDATING a how to for us less technical I believe traction of this product could become mainstream.
I also fully appreciate the point that it requires someone with knowledge to be reading my post to give me an answer.
My problem that kicked all this off was so frustrating and the only relevant post I found on a GitHub said that a repull resolved the problem, I had no idea what a repull was, assuming either a reinstall or restore a backup, I tried a backup but the problem remained.
Apologies for the rambling…

100% no. If you ever have do do anything other than restart home assistant you have more serious problems. My ‘host’ system can be running for MONTHS without any reboot.

Pulling the power is an absolute last resort if the restart server from te menu doesn’t work or you can’t reboot the host. Again, you would seem to have more serious issues. If you have to pull the power, disaster is awaiting just one reboot away…

I have never had a snapshot restore fail… and I have done a lot of them for various reasons.

The best thing you can do is to just bump your thread by posting to it again and someone may see it and respond (like I did today!!)

The documentation is actually quite good and any user can contribute to improving it - it is a community effort. Every doc page has an edit this page link in the top right corner.

This community is AWESOME… if you are persistent and not a dick you will get a lot of people going above and beyond to help you… but do just repost if you don’t get a response or try discord for help as well. People will fall over themselves to help if you approach them with a good attitude.

(I should also add, a reinstall pretty much should never be needed…)

Looks like I’m treading the same path - and about to give up on HA!

Don’t give up. With every release things improve. I actually have started from fresh a few times. My latest install has been pretty stable for months. I think you need to go through the pain to better understand how to fix problems. Thankfully the DNS problem seems to have disappeared. I also use NabuCadasa now and have moved from a RPI to a small Nuc.