Do Zigbee and Zwave dongles work nicely together?


#1

I currently only have a Zwave dongle and it appears to work well. I am considering adding some Zigbee devices, but I wanted to know how well HA works (if it all) with having two dongles.

I currently run HA on an Intel NUC that has an Aeotec dongle for Zwave. That machine runs VirtualBox (Ubuntu 18 host) which in turn has hass.io installed.

I currently have an unused SmarthingsV3 hub. And considering I’m only adding zigbee door sensors, might it not be more cost-effective just to use that instead of getting a stick and send updates to HA? Would that best be done via MQTT?


#2

Not sure about the smartthings stuff, but there are a bunch of users my self included using an all-in-one ZigBee and zwave doungle the HUSBZB-1 which basically shows up as two dongles to the OS. So if you got a ZigBee dongle it shouldn’t interfere with your zwave stuff.


#3

Also not sure about SmartThings but I have an Elelabs Zigbee USB adapter installed side by side with my Zooz Z-Wave USB stick without any problems. This is hass.io on an Asus Tinkerboard.

I originally left my Zigbee on a Wink hub but decided selling the Wink and buying the USB adapter made for a cleaner setup with faster response times. It looks like ZHA is getting a lot of attention in the next few updates including a control panel that is similar to the Z-Wave control panel.


#4

For a long time I had my Aeotec stick and the HUSZBZ-1 stick both plugged into first a RPi then a NUC. they were always right next to each other.

About a couple of months ago I started having intermittent problems with the HUSZBZ stick not communicating correctly with the zigbee devices and then it started to intermittently drop off the hardware bus of the NUC. there were times I actually had to pull the stick and reinsert it and/or reboot the NUC to get it back.

I eventually tried pulling it out of the NUC and using it in my old HA RPi and linking the devices using MQTT to control the zigbee stuff. It’s worked fine ever since. The funny thing is that the NUC & the RPi are sitting 6 inches away from each other on the desk. So I don’t know if 6 inches is enough to prevent interference in the signals or if the USB port I had the stick plugged into on the NUC was getting flaky. But I now have a zigbee2mqtt stick plugged into the same port and it seems to be working OK.

I don’t know if it helps but that’s my experience.


#5

I am currently using an aeotec z-stick and a conbee zigbee stick (controlled by the hassio deconz add-on) with no issues on a raspberrypi 3b. I have about a dozen z-wave devices and only four zigbee ones.


#6

I’ve spent two days trying to get the conbee stick running alongside my aeotec z-wave stick. Hass.io detects the conbee as a raspbee instead of a conbee. Did you use the official deConz add-on along with the deCONZ Zigbee gateway integration?
https://imgur.com/a/54vF3MX


#7

I use the deconz add-on. To access phoscon I had to use my pi’s ip address instead of http://hassio.local:8080 (in place of Hassio.local).

I don’t recall having to do anything else special.


#8

I also had the issue of my conbee being detected as raspbee.

I switched to the marthoc addon in the end:

It works perfectly. I first plugged the conbee into a windows PC, updated the fimrware (and then updated again via the GCFFlasher tool since Deconz wasn’t showing the 262F0500 update).

I also took the opportunity to upgrade the firmware on a couple of my Ikea Wireless Dimmers that had an older version.

I am using conbee alongside a z-wave usb dongle (an Everspring SA413 Z-Wave Plus that only cost £5) and no problems. I do have the conbee plugged into a short (15cm) USB extension to take it away from being right next to the z-wave dongle though.