Doc confusion with MQTT

I didn’t find the answer when I searched but my question is after installing the MQTT mosquito It says the following.
To use the Mosquitto as a broker, go to the integration page and install the configuration with one click:

  1. Navigate in your Home Assistant frontend to Configuration -> Integrations .
  2. Use the Add button and search for MQTT
  3. Configure the Broker, Port, Username, Password and Submit.

But when I clicked MQTT it just said do you want to enable discovery and a check box. Am I doing something wrong because It doesn’t ask me to enter in a port username password etc. in that field my misunderstanding the directions or is it just supposed to be in the configuration Yaml file?

Are you using the MQTT Add-on? Specifically this one?

If so it will automatically pull the required settings. I just did this today and thought it said something to this effect while setting it up.

Yeah I did the one from add on page. Just following the instructions made it seem like I was missing something. But if that’s correct I’ll keep chugging along. Thanks for the prompt response

I still dont understand something. How do I now know what is my mqtt username? I made a new user as per instructions, but it is just a generic user. How does mqtt addon know what username to set up? It didn’t ask me anything. Something is wrong with the docs.