Docker Bind Mount Question

I recently switched over to Home Assistant OS from a Docker container. I installed Portainer and am trying to run some Docker Compose files, but I keep running into an error message that’s saying it’s a read only file system where I’m trying to map my bind mounts. I’ve tried putting them in several places, under /data, /config, and /addons, all with the same error message. I’ve also tried chmod’ing the directory for the bind mount to 777 with no luck.

My question is, is this expected behavior, or am I doing something wrong? I know that a lot of the Home Assistant OS is read only, but I thought directories like /data and /config were writeable. Do I need to chown the directory to the user Portainer runs as? Also if there is some other way to install docker-compose, I’d be fine not using Portainer.

I’ve tried Googling this quite a bit, but most of the results I find have to do with running HA itself in a container. I did see one suggestion to just use Docker volumes, but I’d prefer to have a persistent directory mapped to the host. Any help pointing me in the right direction would be greatly appreciated.


That should be fine, changes are propagated immediately to the host with volumes, that is how it is used in the regular Docker-HA for the config dir.

Would that give me persistent storage in the container if I were to wipe out the volumes though?