Docker - custom component (vicare) not working

Hi folks,
Just a small problem regarding vicare integration:
The error says

Logger: homeassistant.setup
Source: components/vicare/
First occurred: 16:07:22 (1 occurrences)
Last logged: 16:07:22

Error during setup of component vicare
Traceback (most recent call last):
File “/usr/src/homeassistant/homeassistant/”, line 174, in _async_setup_component
component.setup, hass, processed_config # type: ignore
File “/usr/local/lib/python3.7/concurrent/futures/”, line 57, in run
result = self.fn(*self.args, **self.kwargs)
File “/usr/src/homeassistant/homeassistant/components/vicare/”, line 70, in setup
vicare_api = Device(conf[CONF_USERNAME], conf[CONF_PASSWORD], **params)
File “/usr/local/lib/python3.7/site-packages/PyViCare/”, line 40, in init
self.service = ViCareService(username, password, token_file, circuit)
File “/usr/local/lib/python3.7/site-packages/PyViCare/”, line 58, in init
File “/usr/local/lib/python3.7/site-packages/PyViCare/”, line 219, in _getInstallations[“entities”][0][“properties”][“id”]
KeyError: ‘entities’

  • I’ve tried to reinstall vicare by deleting the configuration in configuration.yaml
  • I’ve unsuccessfully tried to locate the files - but I’m on docker and have no Idea where the files are located
  • I’ve restarted homeassistant
  • I’ve updated to 107

Any Ideas for further analysis?

Greetings and Thanks in advance