Docker installation on Raspbian puts up a tease and doesn't show the UI

I can see two containers running:

docker ps
CONTAINER ID        IMAGE                                   COMMAND                  CREATED             STATUS              PORTS               NAMES
1ca22351fa51        homeassistant/armv7-hassio-supervisor   "/bin/ pytho…"   12 minutes ago      Up 12 minutes                           hassio_supervisor
ac9b08f2b5fd        homeassistant/armv7-hassio-dns:1        "coredns -conf /conf…"   13 minutes ago      Up 12 minutes                           hassio_dns

But if I try to go the IP on :8123 it doesn’t show anything?

I just wanted to try out the ‘usb3 boot on rpi4’ method that Andreas Spiess showed, and it boots up nicely (starts on the SD and then switches to the USB ssd).
I wish RaspberryPi4 would be allowed to boot from the usb directly, but this seems like an ok workaround.
But I don’t see anything show up on port 8123?

I take it you followed this guide?

Also, what does docker ps -a show?

1 Like

Yes, exactly. For now I’ve had to revert to the normal SD card, as the family was bothered by everything being down :slight_smile:
I’ll have a go at it again soon.

Does your system respond to a ping command? Is is configured for a static IP?

1 Like

Yes, yes :slight_smile: And I can log in with SSH

You may need to do sudo firewall-cmd --permanent --zone=public --add-port=8123/tcp if firewalld is running.

To see if it’s running sudo systemctl status firewalld

Or the equivalent iptables commands.

1 Like

Oh, firewall, dooh, that could very well be it. But as I said, I unfortunately had to abandon the attempts for now, before the WAF drops too low :laughing:
But I’ll keep this in mind when I reattempt, I have the ssd and the sd ready for a new attempt.

1 Like

Ok, I tried again now that the rest of the family is getting to bed :smiley:
I started over, now I see the landing page, so something went wrong the first time.
But DARNED, that is fast now :-o
Can’t wait to see if I can get everything up and running…

Ok, so now I got a bit further. I’m currently trying to restore a backup. I can see most of the addon’s has restored, and started, such as the SSH addon, unifi controller, adguard, but so far not HA itself. I hope it will wake up soon…

Ok, that is weird. My Firefox kept complaining about bad communication, so I started chrome, and that started the HA UI immediately???
So after shutting down all the FF windows, I tried starting it again, and now it shows the UI.
So now it’s running on a RPi4 with a 240 GB USB3 SSD, it really helped on the speed.
I’m going to move the DB back to the RPi4, and now I will even consider adding the influxdb and grafana.

1 Like

It could’ve been you needed to clear the browser cache. The next time it happens in Firefox, type CTL+F5.

1 Like

No, I tried that, also clearing the cache completely, oh well, something got stuck, and is now un-stuck.
But great suggestion anyways.

1 Like