Docker installation with Multiple NetworkCards [Solved]

Running HA as a docker works fine, but I am ramping up my home LAN security and I am moving all IOT devices in a non Internet Connected VLAN.
All LAN traffic is routed on my Firewall and works fine.
But due to a limmitation in some intergrations I am not able to change configuration or Discover some devices (for example my Airco unit) as I asume this is discovered via a Layer 2 broadcast (thus not forwarded to any other VLAN.

My HA docker runs in VLAN A (Internet Connected) and my IOT devices are in VLAN B.
To work with the mentioned issue I want to add another NIC (configured in VLAN B) to my HA Container. But so far no luck.

I am working with MACVLAN in my docker compose file and this works great for other containers but so far no luck with the HA container as it only shows the first network mentioned in the Docker-Compose config DockervlanA

    container_name: HomeAssistant
    image: homeassistant/home-assistant
      - /share/docker/HomeAssistant/config:/config
      - /etc/localtime:/etc/localtime:ro
    restart: unless-stopped

But no second NIC in the system/network

Anyone a tip how to get my docker running with multiple NICS ?

WOW that escaleted Quickly :slight_smile:
Now the auto configure option caught my eye … well that did the trick removed that tick et voilla … now I am able to select the other NIC :slight_smile:

Thanks for reading :slight_smile: Isuue solved

Hey I know this is a few months old, but I’m running into the same issue with a reolink camera on a separate vlan.

I went through and selected the other NIC (VLAN 20 - br0.20), but still no luck getting the HA Container (on VLAN 1) to connect. I can ping VLAN 20 from VLAN 1 no problem, just can’t get HA to connect to anything outside of VLAN 1. If you have any advice or thoughts it’d be appreciated. Thanks!

Does your docker container host have access to VLAN 20 ? (in other words is the Network interface card / switch properly configured ?