Docker Mac missing devices

Hi,I use to run Homeassistant on RPI and it worked.

Move docker on a mac. (Kitematic)

The most works but It does not show Sonos and Samsung tv.
Kodi and Chromecast shows up.

Please same suggestions?

Im guessing they are not showing up automatically?

Have you tried adding them manually?

Yes they are added manually.

As they both require specification of an IP address as part of the config, are you sure you have the correct IP? Are those devices on a static IP reservation in your router?

If that is not the issue, check your error logs and post here if needed. They should provide some insight.

Thanks for taking your time,

Have tried 2 ways


  • platform: kodi
    port: 8080
  • platform: sonos
  • platform: samsungtv
  • platform: cast

2017-09-20 20:01:22 WARNING (SyncWorker_4) [homeassistant.components.media_player.sonos] No Sonos speakers found
2017-09-20 20:01:25 WARNING (MainThread) [homeassistant.setup] Setup of media_player is taking over 10 seconds.


2017-09-20 20:05:33 ERROR (MainThread) [homeassistant.components.media_player] Error while setting up platform samsungtv
Traceback (most recent call last):
File “/usr/src/app/homeassistant/helpers/”, line 164, in _async_setup_platform
SLOW_SETUP_MAX_WAIT, loop=self.hass.loop)
File “/usr/local/lib/python3.6/asyncio/”, line 358, in wait_for
return fut.result()
File “/usr/local/lib/python3.6/asyncio/”, line 245, in result
raise self._exception
File “/usr/local/lib/python3.6/concurrent/futures/”, line 55, in run
result = self.fn(*self.args, **self.kwargs)
File “/usr/src/app/homeassistant/components/media_player/”, line 74, in setup_platform
ip_addr = socket.gethostbyname(host)
socket.gaierror: [Errno -2] Name or service not known
2017-09-20 20:05:38 WARNING (SyncWorker_16) [homeassistant.components.media_player.sonos] No Sonos speakers found
2017-09-20 20:05:41 WARNING (MainThread) [homeassistant.setup] Setup of media_player is taking over 10 seconds.

But no sonos neither samsung tv showing up
This configuration works on Raspberry Pi

Did you figure this out? I have just the same problem.

No I haven’t.