Docker openzwave control panel, Configs go where?

Hi all,

My Raspberry pi crashed :frowning2: and I had to rebuild. I decided to go with a Linux server (fresh image) running Ubuntu 16.02 LTE and use Docker.

I have docker running MQTT (more on that in a bit…) and Home-Assistant. I needed to run the openzwave control panel (aka ozwcp). That wasn’t found in the Home-Assistant docker image, so I started up the docker image Openzwave/openzwave-control-panel.

It sees my Aeontec 5 gen stick and found all the devices…Great! Saved it…umm WHERE does it go? There aren’t any paths mapped to the host system, I checked

Anyone know anything about this? :pray:

How do I find them? Can anyone give me a filename I could search for?

oh and BTW if you need to access a service in another container like mqtt, add link=mqtt:mqtt and then change the hostname from to mqtt.

here are my startup files for the images, for the next guy…


sudo docker run --detach
-p 1883:1883
–name mqtt
–restart always


sudo docker run --detach
–hostname europa.home
–publish 8123:8123
–name “home-assistant”
–restart always
–link mqtt:mqtt
–volume /srv/homeassistanr/config:/config
–volume /etc/localtime:/etc/localtime:ro

sudo docker run --detach
–hostname europa.home
–publish 8008:8008

Thank you for MQTT tip. I knew this was possible but never considered this configuration for some reason.

In you Home-assistant volume you have “homeassistanr”.
Was that a typo?

Yes, I caught that late last night. I think the files are inside the container at /home/ozwcp_user/openzwave & /etc/openzwave directories…

Now it sees the Zwave controller but all the devices are showing up in HA as unknown types.


Oh man… I struggled with this for a long time.

There is no config directory in the OZWCP docker… everything (config / executables / etc) is in the same directory. What you have to do is override the individual files you want to share with other containers. Do something like this.

docker run -d --name="ozw-cp" -u 0 -p 8008:8008 --device=/dev/ttyUSB0 -v /etc/hass/zwcfg_0x016a2e06.xml:/home/ozwcp_user/open-zwave-control-panel/zwcfg_0x016a2e06.xml openzwave/openzwave-control-panel

Hats off to reddit for this solution.

I’m also sharing the options.xml file.

Can you define unknown type?
Do you see data returned?(sensor value or boolean)

Zwave kinda just worked for me.
Have you tried configuring in Open Zwave Control Panel?
In OZCP you should be seeing data and sensor type.(I believe, been a while since I looked at that)

HA should not be running when connecting to OZCP if I remember correctly.

how are you sharing the options.xml file between containers?

@droberts84 tells above.

He has volume configured to share file from host to container. Look at his docker run command