Documentation's search function doesn't work

I reported this problem (4 days ago) in’s GitHub repo but it hasn’t been acknowledged yet.

The documentation’s search function does not work. Normally it displays an input-box where you can enter your search string but now it displays nothing.

I tried three different browsers with the same result. The absence of a search function makes it more challenging to find information.

Search is actually improved? Some kind of adblocker possibly? Do you see the magnifying glass icon?


Thanks for the reply.

Yes, I’m using pi-hole to block ads but I don’t understand how that would cause this issue. The do see the magnifying icon and its URL is which is not blocked by my pi-hole.

I’ve tried the following browsers (none have additional ad-blocking software) with the same results:

  • Firefox on Android
  • Chrome on Android
  • Firefox on Linux
  • Edge on Windows

I’ve checked pi-hole’s logs and there’s no report of any blocked requests related to

I definitely do no not see the screenshot you posted. All I see is the magnifying glass becomes selected:

Screenshot from 2020-06-08 12-15-09

The search is powered by a service called Algolia so maybe check your Pi-Hole logs / block filter for that term?

My complete guess is that your Pi-Hole (or some other browser extension/adblocker) is blocking that Algolia logo (or javascript) and then causing the other UI elements to not display as well.

I know that Paulus updated the search exactly a week ago to make it now search through Integrations docs pages. So there was in fact a recent change around the time it broke for you. But I’m unable to reproduce this on any of my browsers (Chrome, Firefox, mobile Safari etc).

I know Algolia was also used prior to the recent enhancement and it never caused any issues with pi-hole (i.e. I was able to access the search function).

Nevertheless, given the fact I can’t use the search function from any machine on my network, it stands to reason that pi-hole, being the common factor, must be the culprit (despite the lack of any logged reports of blocking).

I temporarily disabled pi-hole and I was immediately able to access the search function. OK, so it appears to be the culprit after all. I re-enabled pi-hole and expected to lose access to the search function. However, to my surprise, I didn’t; the search function continued to work. I closed/re-opened the browser, flushed its cache, etc and was still able to use the search function.

It’s unclear to me why disabling/enabling pi-hole cleared up the error, but it did. Maybe the action cleared/refreshed a cache; beats me but it works now.

Thank you both for your assistance. I’ll close out the Issue I posted in the GitHub repo.

I can only assign a Solution to one of the posts that assisted me. I’ll grant it to cogneato’s post for being the first to correctly suggest the problem may be due to ad-blocking.