Does anyone know where I can find older install image for rpi 3B?

I have tried erverything in my power to make this image: Raspberry Pi 3 Model B and B+ 32-bit install on my pi. But it really does not work. I have tried several different sd cards, different power supplies, cables, network connection methods, different versions of BalenaEtcher… no dice it just WONT install. exactly nothing happens when I boot up the pi… this have frustrated me a whole lot the last couple of days, and for that reason I decided to install HS in side a docker container, buuuut found out that it is not a supervised version so I can’t install the addons that I need… or at least not easily. I then tried installing the Home Assistant Core this installation method also worked like a charm, buuuut this also didn’t ship with the addons store that I need.

About a year ago I flashed a Home Assistant OS image onto an sdcard and it did in fact install after I powered up the pi. The current image on the download page has to be a newer one with some changes done to it that just doesn’t work for my setup (pi version - whatever…)

I would really like to find older version of the installation image because I am absolutely sure that if i just get an older one I will be able to install Home Assistant OS again like I did last year.

Thanks in advance!

For the record, I have also tried the 64bit image, exact same result, nothing happens, no network connectivity, it never even preforms a handshake with my router over ethernet. nothing written to any of the files on the sdcard, nothing on the screen when hdmi connected - nothing.

EDIT: since many of you ask for the steps I followed…

1: downloaded: Raspberry Pi 3 Model B and B+ 32-bit
2: downloaded:
3: flashed the image onto a Class A1 32GB micro sdcard
4: insert sdcard in rpi b3+
5: insert ethernet cable in router + pi
6: turn on the pi
7: waited up to 2 hours - pi never shows up when scanning with

One thing that is worth to mention, is that as soon as i plug the power in the pi the red LED goes solid, the green blinks two times, and then never blinks again. This ONLY happens when sdcard with the lates hassOS image flashed is inserted, with all other images, the green LED is more active and most important of all, the etherned LED as well.

I would like to branch my steps… because as described, I have done a lot of different things to try and make it work. I have used 3 different sd cards, one class A2 16GB and another class A1 16GB. I have verified all my sdcards with h2testw to be fully functioning and be fast (10MBps write 20MBps read)
I have tried different power supplies and usb cabels. I have tried different port on my router, and different ethernet cabels, I have tried the version of BalenaEtcher I had already installed, and I have also flashed using the latest. I have also tried the wifi connection method by using a USB stick formatted FAT32 with only one partition called CONFIG network/my-network/my-network with the wifi configuration. For this step I followed this video: time: 3:00 - 5:20

That’s definitely not a good idea to install a 1 year old version of home assiatant. We’d rather find out why the new image doesn’t work.

  1. Flash the image to the SD-card with Balena Etcher (no unpacking of the .img.gz file)
  2. Put the SD-card into the Pi
  3. Plug in the Ethernet cable
  4. Plug in the Power cable
  5. Wait at least 20 min
  6. Check if you can see the Pi in your network
  7. Go to http://ip-of-your-pi:8123

If this procedure doesn’t work, please tell us at which step you got stuck.

To rule out the Pi being your issue, you could also try flashing Raspbian on the Pi and see if this works.

You actually don’t need Supervised to run addons; They are basically just Docker container apps that have been tweaked to easily integrate into Lovelace. You can run those same addons in their own containers and then manually add them to HA.

Which addons do you need to run?

1 Like

Installing the latest HassOs cannot be a problem. Aren’t you doing something wrong? As already mentioned, describe your steps and we will help you.

Hey thanks for you response :slight_smile: When I say I have done everything in my power I really mean it. Yes I have followed that exact procedure like 8 times swapping out sd cards, power supplies, ethernet cables, usb stick with wifi settings etc etc. waiting up to hours some times I have left my house to comeback later still no dice. It never even blink once on the ethernet activity indication led, not on the pi and not on the router.

To rule out the pi, I have installed raspbian on the sdcard as well which boots up perfectly and become available on the network, same goes with other old sd card I had laying around with some other linux ditribution, boots up perfectly and comes online.

Arhhh hello there chief. That’s a bold statement
OP edited with my detail.

When you burn the image. Do you see any files on the SD card afterwards?

I have a Pi laying around, will test with you :slight_smile:

1 Like

This is what the sdcard look like. Also balenaEtcher valides the flashing to be successfull


I have update my initial post with a little more detail about the steps I followed.

Just out of curiosity, what firmware version is on your rPI3B+? When was the last time you updated it? You might want to pop in your Rasbian card, boot it and run sudo rpi-update and let it update the firmware. This is something that normally happens when the rPi is in use and I’m not sure if hassos manages the firmware updates or not.

The reason I’m going down this road is because the newer version of HASS might require a newer version of the rPi firmware and if your firmware is older, it might be preventing it from booting.

1 Like

It’s strange that it works with all the other OS and images. You could try downloading an older version from here, but choose something relatively new such as 4.11, not something from 1 year ago.

I’m still backing up the image of the Pi.

1 Like

Thanks! This could be interesting, I never manually did a firmware update of that pi no. Will try this, and see if that has any effect

Edit: I have now performed a manual firmware update,

But unfortunately this does not seem to have made a difference, I just inserted the hass-boot sd card, and the same LED behavior as before, solid red, green blinked twice. zero activity on the ethernet LED… :grimacing: Will give it half an hours wait and see if any change.

I’m afraid that the FW in eprom is only on Rpi4. On older versions of Rpi, the FW replaces the config.txt file

1 Like

Seriously? I thought that the eeprom was upgraded as well on the 3B+. Crap.

If what @pepe59 is saying is correct, then it probably won’t make a difference. Maybe you might want to try the Docker route on your rPi and many of us can help you install addons manually (it really isn’t as difficult as it sounds). I for one would be happy to help if you want.

Maybe a silly question. How did you format the SD? I have experience that in win10 when I format the SD and look at it so it is clean, but the old boot partition remains what is not visible. Can’t you have the old boot partition on the SD?

I never manually edit the partitions of my sd cards, isn’t BalenaEtcher managing that for you? (if not it should probably be included in the install steps). Every time I flash something with BalenaEtcher it have worked, except this one image in question. one of my sd cards was freshly unboxed yesterday, the other have had raspbian etc. on them which works just fine.

Alright, I will try the 4.11 version image first. and if this still does not work for me. I will have to go the docker route again yes.

1 Like

You could do a Home Assistant Supervised install instead. This will also give you Add-ons, snapshots etc., but it is installed on top of a Raspberry Pi OS instead of HA OS. There’s an excellent guide for this here.
But try the older images first.

I’m sorry but I realized that the Pi I have laying around is a Pi 4 :frowning: so I can’t replicate your process.

1 Like

OK. One more try. Format the SD to make it completely clean. I use Win32DiskImager. Balena never worked for me. I also use Rpi4 today and I also can’t replicate

1 Like

Good advice, thanks! Would you suggest that I manually delete existing partitions with the windows disk manager before using the imager ?

Yes in Disk Administrator. There, delete partitions, merge and format