Does HA Supervised have to run as root?

I just finished installing Home Assistant Supervised on Ubuntu 18.04 (on an old laptop). The documentation’s instructions were accurate and I now have Home Assistant 0.108.6 running successfully (a.k.a.

All of the installed files in /usr/share/hassio belong to root. That’s expected since the installation instructions demand that you use sudo -i prior to executing all the suggested commands.

However, is it possible to perform the installation so that it runs as a user (i.e not as root)?

I’ve previously installed Home Assistant Core in a virtual environment (venv) and as a docker container where, in both cases, it runs under an account without root privileges. I’d like to know if that’s also possible for Home Assistant Supervised.

FWIW, I’ve tried executing the final installation step without sudo and the script fails when it attempts to create the directory usr/share/hassio (because you need root privileges to create a directory in usr/share).

curl -sL "" | bash -s -- -m qemux86-64

I inspected the installer script and it appears to accept options to specify alternate locations for the directories it creates. Has anyone tried using the options to perform the installation using a non-root account?

1 Like