Does Hacs work on hassio?

Can anyone tell me if I can use hacs with hassio? Because I cant seem to find/get the hacs integration from the list.

1 Like

I did that already, i ran this command and it supposedly worked:

Screen Shot 2021-07-24 at 3.25.30 PM

and then I restarted hassio, cleared the browser cache con my mac…was i supposed to clear the cache on the raspberry pi somehow? How do I do that?

Because hacs doesnt show up in the Integrations list.


If it doesn’t show up there, the last time I fielded a similar question the user had some garbage in /config/custom_components that was preventing HA from loading anything in there. Review your logs.

ok here is a screenshot of whats in my config/custom_components/ folder:

Screen Shot 2021-07-24 at 6.53.15 PM

Thats everything I downloaded from the github:

looks like you installed it in the wrong diectory. Do NOT change to cusom_components before running the script. The instructions are:

  1. Connect to the SSH add-on
  2. Run the HACS install script

All of that should be in a hacs folder in /config/custom_components, rather than directly in /config/custom_components.

ok so how do i fix it now?

From /config/custom_components:

mkdir hacs
mv * hacs

Then restart HA

ok i moved everything and it still doesnt work. I restarted the whole raspberry pi.

Frankly I would delete the whole hacs directory and start again, following the instructions this time.

ok i removed the entire directory and went into the ssh addon and ran the script:

I restarted the raspberry pi and i still cant get hacs listed in the integrations. There is nothing else inside the custom_components folder except the hacs folder.

Have you followed this guide?

ok i had forgotten to do the cache thing this time around, so instead of clearing it i opened up an incognito window and it worked, i added hacs and apparently it has changed, because it no longer asks you for a token, instead it asks you to connect to your github account and i guess thats how its done now.

I will continue with sonoff lan now. thanks so much