Dome DMWD1, how to chang to binary for HA?

I have a pair of these dome sensors and I’ve got them added to my HA without issue, but they are not updating when the i open doors/windows.

I know from a previous issue with some water sensors i had to change the “Report type to send” from 255 to 17. However on these devices I can’t find that option anywhere. Using both the HA zwave config or OZWCP. Its not listed in the configuration.

If you use the binary sensor that was created when you added the sensor, you shouldn’t have to change any parameters of the sensor.

It should be something like: “binary_sensor.dome_doorwindow_sensor_sensor

There were 5 entities created when I added the sensor

- sensor.nursery_window_1_access_control
- sensor.nursery_window_1_alarm_level
- sensor.nursery_window_1_alarm_type
- sensor.nursery_window_1_sourcenodeid
- binary_sensor.nursery_window_1_sensor

None of these update when I separate the magnets.

Then there is another issue, remove the sensors and re-add them, after you remove them, delete the entity ID’s from the entity file, after you re-add them, keep the sensor and magnet separated for a few minutes then restart HA.

Thanks, unfortunately I’ve tried most of that already. I’ll just keep tinkering.

Zwave battery devices are a bit of a PIA to deal with in HA.

I added 6 of them last week and haven’t had any issues, or had to make any changes.

If you need to change the parameter settings, it is done via the Z-Wave configuration in HA.

Advanced Manual.

Im just not sure what Is happening here.

I add them, The entities show up. Everything looks good. But when I separate the magnets, HA or the Zwave network dont show any changes. I have the OZW.log running so I can watch for changes, but it doesn’t show.

I’ve tried restarting with the magnet separate at first and together. Each time I remove and re-add them I remove it from the entity registry also.

I’ve tried checking in OZWCP to see if it updates and even there it does not see the change.

Im 4 feet away from my Zstick, no obstructions.

These are brand new sensors with new batteries (double checked they were full). Two identical sensors, same issue.

In HA, go to /config/zwave, and see if they show up as nodes.

Maybe try one at a time.

they show in my list. That is not the issue. The device is added to my zwave network.

The issue is the entities created are not updating on state changes. ie, when the physical magnets are seperated, no notification is being sent to the zwave network.

binary_sensor.nurserl_window_1 is not updating.

Check whether the number of sensor.Nursery Window 1 Alarm level changes?


None of the entites listed change. I have a running tail -f of both the OZ log and the Home-assistant.log

Nothing is seen in the logs, or in the entity displayed.

Did you add them as regular or secure?

I tried both. Same issue

Sorry, I have no idea what is wrong.

When I added mine, I left the cover off for about 5min, this forces the sensor to stay awake and the system is able to get all the parameters of the sensor.

forces it to stay awake? How? There is only one button. There is no switch or sensor that detects if the cover is on or not.

I’ve had the cover off the entire time while I try and figure this out.

are we talking about the same model sensor here? Dome DMWD1?

Yes, I meant I forced it, by pressing and holding the BUTTON
for two seconds.

I think Im going to return these and switch to a different style.

Either I got a bad batch, or something else is broken. THis is really not worth the hassle.

Are those the only Z-Wave devices you have?

nope. I have: 2 water sensors, 9 switches(ge and leviton) and 2 thermostats.

All were added and worked “out of the box”, except for the water sensors which I had to change the report type.

But other than that, working great.

Did you try a system reboot, not just HA restart?

Heal Network, Soft Reset, etc…?