Dome Water Shut-Off Valve + Cant get it to work with Automation

Hello All,

I am new to and the community and I am really struggling with getting this Dome Water Shut-off Valve to work, I have purchased a Valve switch and a water sensor but no matter what I do I cannot get the Valve to turn off when an automation goes off. Forgive me as I am using the GUI (been playing with this for less than 48hrs) but I tried many a few different things to try and get this to work and I thought maybe it was the the water sensor I was having issues with but it appears to be the valve itself. I can get the valve to turn on and off by clicking on it via the gui but I can’t get it to set off on automation and looking for some guidance.

I have tried other automations to make sure I had a slight idea of how it works and was able to get things like Turn on X light when I turn on X lamp so I tried to get the valve to go off via lamp on since I knew I had that down but it does nothing.

I have Call service as the action
service - switch.turn_off
service data
" entity_id": “switch.dome_water_shutoff_valve_switch”

but nothing happens, anyone have any insight on what I might be doing wrong? the valve is set to on by default meaning that the valve is open and I want to figure this out so it can turn off when the sensor senses water but one step at a time if I cant get it to move when I turn on the lamp I’m obviously doing something wrong.
Thank you in advance for any insight whatsoever, as I’ve tried to look up similar situations online but couldn’t seem to find anything.

here’s an automation I wrote for vacation mode of my house, this includes a dome water valve shutoff as well. Please keep in mind I’m pretty much a noob as well, and I literally just cobbled this together, so it may not be perfect.

# on vacation, close the main water valve, set temperatures back, set water heater to vacation, & turn off recirculation pump
- alias: "on vacation"
    - platform: state
      entity_id: sensor.vacation_status
      to: "true"
    - service: homeassistant.turn_off
      entity_id: switch.water_main_shutoff_switch
    - service: climate.set_temperature
          - climate.thermostat_upstairs_heating_1
          - climate.thermostat_main_heating_1
          - climate.thermostat_basement_heating_1
        temperature: 62
        operation_mode: Heat
    - service: climate.set_temperature
          - climate.thermostat_upstairs_cooling_1
          - climate.thermostat_main_cooling_1
          - climate.thermostat_basement_cooling_1
        temperature: 85
        operation_mode: cool
    - service: econet.add_vacation
        entity_id: water_heater.heat_pump_water_heater_gen_4
    - service: homeassistant.turn_off
      entity_id: switch.insteon5
- service: notify.pushover
    title: "Ran vacation mode: on!"
    message:  "turned off water main, set back temps, turned off recirc pump, set vacation mode on water heater"

Thank you so much, I changed my service from switch.turn_off to homeassistant.turn_off and it is now working. Thank you very much I appreciate the assistance as this one was really important to me.
I updated it to now turn off when my water sensor goes off and it works like a charm.

1 Like