DoorBird integration no longer working

A few days ago (maybe after upgrading to core-2021.3), my DoorBird integration stopped working. I removed the integration and tried to reinstall the integration. I now get this error in the log:

Logger: homeassistant.config_entries
Source: helpers/network.py:124
First occurred: 11:06:57 AM (1 occurrences)
Last logged: 11:06:57 AM

Error setting up entry 192.168.220.162 for doorbird
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/config_entries.py", line 248, in async_setup
    result = await component.async_setup_entry(hass, self)  # type: ignore
  File "/usr/src/homeassistant/homeassistant/components/doorbird/__init__.py", line 160, in async_setup_entry
    if not await _async_register_events(hass, doorstation):
  File "/usr/src/homeassistant/homeassistant/components/doorbird/__init__.py", line 204, in _async_register_events
    await hass.async_add_executor_job(doorstation.register_events, hass)
  File "/usr/local/lib/python3.8/concurrent/futures/thread.py", line 57, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/src/homeassistant/homeassistant/components/doorbird/__init__.py", line 281, in register_events
    hass_url = get_url(hass)
  File "/usr/src/homeassistant/homeassistant/helpers/network.py", line 84, in get_url
    request_host = _get_request_host()
  File "/usr/src/homeassistant/homeassistant/helpers/network.py", line 124, in _get_request_host
    raise NoURLAvailableError
homeassistant.helpers.network.NoURLAvailableError

Can anyone confirm that this integration works with core 2021.3 ?
Any ideas?

I have the same problem, I downgraded to core-2021.2.3 from core-2021.3.2. And it started to work again.
Not sure why yet. Have not found anything in the bug tracker about it. I will keep looking and if I come to some sort of conclusion about what it is, I will try to create a ticket for it

Small update and possible solution.
I created ticket https://github.com/home-assistant/core/issues/47614
Got a question if I did have URL configured (and I did not)

I added URL below Homeassistant: tag in configuration like this: (replace X’s with your data)

external_url: “https://XXXXXXXX.duckdns.org
internal_url: “http://192.168.XXX.XXX:812/

After this, it worked fine on core-2021.3.2

Wow! Looks like you are right!

Thank you so much :slightly_smiling_face:

I just updated from core-2021.1.5 to 2021.4.4 and hit this issue.

HOWEVER, I configured doorbird through the ConfigUI, not through YAML, and I don’t see any way to add this configuration via the UI?

Alas, I cannot reply to the Issue because it’s been closed/locked. Maybe @bdraco can respond here instead of there? :slight_smile:

I created Doorbird Integration fails without URLs, but no way to configure them in ConfigUI · Issue #49172 · home-assistant/core · GitHub to record this.

This has been resolved. For the next person who hits this, go to Configuration → General
There you will find the External URL and Internal URL settings.
Once you set those (and Save) you can either restart HA or reset the Doorbird integration.
To reset it, go back to Configuration → Integrations → Doorbird, disable the integration, and re-enable the integration to get it to restart. After doing the Disable/(re)Enable procedure, the Doorbird integration is working again.
Thanks to @nilst for pointing me in the right direction.

2 Likes

Hello, I have this issue using Hassio 2022.2.5
I can’t find the entry for External URL and Internal URL when I go to configuration → Settings.
And when I add the external url and internal url as described here, it tells me that the configuration is not valid and the integration is not found

@roberreiter – I am still using 2021.11.5 so I haven’t quite hit the new configuration UI layout, yet.

I would recommend you NOT follow those instructions to configure via YAML, because if you try to configure via YAML then you can’t configure via the UI. You should be configuring via the UI.

I suspect the location of those settings moved between 21.11 and 22.2. I only upgrade every 3-4 months. But I would suggest you remove that configuration and then configure via the UI to find the Internal and External URL settings. I’m sure they still exist, somewhere, but I don’t have a 2022.2 install to find them for you.

Hello,
I can’t find this option anywhere

What do you see under Configuration → Settings?

Sorry, my German isn’t very good. But something definitely looks wrong.
Does your “Configuration” page look like what you see at 2021.12: New configuration menu, the button entity, and gorgeous area cards! - Home Assistant

Yes, it looks like the configuration page there, and when I click on “Einstellungen” which is “settings” I see the page I already posted before

Hi, just found it.
I had to activate the advanced mode features in the user menu for user settings.
Now I included the external and internal IP and it works

I wanna ask sidenote…
Does Doorbird support 2 way audio inside HA?

1 Like

Thank you.
It works on:
Core 2022.3.4
Supervisor: 2022.3.4

Intersting for any solution.