Duck dns addons with let's Encrypt doesen't work

my settings are:

“lets_encrypt”: {
“accept_terms”: true,
“certfile”: “fullchain.pem”,
“keyfile”: “privkey.pem”
“token”: “xxxxxx-xxxx-xxxx-xxxxxx-xxxxx”,
“domains”: [
“seconds”: 300

the console is giving this error:

starting version 3.2.4

INFO: Using main config file /data/workdir/config

ERROR: Problem connecting to server (get for; curl returned with 6)

Check you indentation your settings should be like this, also you have a curly bracket missing at the end

      "lets_encrypt": {
        "accept_terms": true,
        "certfile": "fullchain.pem",
        "keyfile": "privkey.pem"
      "token": "YOUR_TOKEN_GOES_HERE",
      "domains": [
      "seconds": 300

I had the exact problem with my Hassio installation on Ubuntu. I had installed Hassio on instead of docker ce. After using docker ce everything worked fine.

The problem was that the network settings were wrong in docker so I couldn’t even ping or

this was a copy error but i tried and still don’t work

i have it installed on a raspberry i also changed resolv.conf with google dns
like that
and i can ping google

Same problem here

1 Like

Having the same problem here:

# INFO: Using main config file /data/workdir/config
ERROR: Problem connecting to server (get for; curl returned with 6)

I am using 0.75.3 with HassOS.
I can ping and no problem.

Anybody was able to solve it?

Hi Matto.

I had exact same problem. I have NUC / Docker / / Duck DNS with Lets Encrypt

Found a comment on the Reddit forum where someone mentioned they followed this;

It fixed it for me too.

Good luck!

This issue was discussed in several forums … and I found the below steps which work for several people in meanwhile. It is a clean fresh install and usually works… the port management is essential here.

Step 1. Uninstall DuckDNS and lets encrypt from HassIO.
Step 2. Goto your routers port forwarding settings. Forward port 80 external to 80 internal at your pi's IP. Do the same with 443 external to 443 internal at your pi's IP.
Step 3. Re-Install DuckDNS with your key, accept terms and domain and start the add-on. Keep refreshing the logs down the page to ensure that DuckDNS has created the certs. This may take 10-15 mins it did for me.
Step 4. Once DuckDNS has created the certificates add these lines to your configuration.yaml
http: base_url: ssl_certificate: /ssl/fullchain.pem ssl_key: /ssl/privkey.pem api_password: Secure password
Step 5. Go into your routers port forwarding settings delete the port forward 80 external to 80 internal and change 443 external to 8123 internal at your pi's IP.
Step 6. Restart Home Assistant and navigate to or whatever your domain is. Enter your password set in api_password: and log into Home Assistant.
This video is also a good guide-

Thank you both so much for your answers. I’ll give it a try and let you know how it goes.

I ended up making a clean install of and everything works now :man_shrugging:

Thanks a lot for your help anyway. I’m sure it will be useful to someone.