Duck DNS help needed


#1

Hi! I have successfully configured access via Duck DNS on an previous Raspberry Pi Hass.io setup.
Having endless problems on a new/current setup.
This is my Config:
{
“lets_encrypt”: {
“accept_terms”: true,
“certfile”: “fullchain.pem”,
“keyfile”: “privkey.pem”
},
“token”: “MY TOKEN”,
“domains”: [
https://MY URL.duckdns.org
],
“seconds”: 300
}

And this is my Log:

INFO: Using main config file /data/workdir/config

  • Generating account key…
  • Registering account key with ACME server…
  • Done!
    Thu Nov 29 11:06:21 SAST 2018: KO

INFO: Using main config file /data/workdir/config

  • Creating chain cache directory /data/workdir/chains
    Processing https://MY URL.duckdns.org
  • Creating new directory /data/letsencrypt/https://MY URL.duckdns.org
  • Signing domains…
  • Generating private key…
  • Generating signing request…
    end of string encountered while processing type of subject name element #1
    problems making Certificate Request
    Thu Nov 29 11:11:44 SAST 2018: KO
    Thu Nov 29 11:16:45 SAST 2018: KO
    Thu Nov 29 11:21:47 SAST 2018: KO

Any/all help/advice/guidance would be most welcome, please!


#2

Try to remove https:// from the domain name.


#3

Many thanks! Config/Log now looks good but still can;t access :frowning:
Your help is appreciated.


#4

Have you checked your router ports so they redirect correctly?
I had massive issues setting up DuckDNS and Let’s Encrypt but in the end it was simple mistakes made by myself.


#5

Yes, ports appear to be correctly set up and open/accessible.
Thanks again for your help!


#6

In your configuration.yaml, check the base URL address, it should be the complete DuckDNS URL including https:// and the :port number being used, in most cases that is 8123.