DuckDNS add-on transmits wrong public IP address

I’ve had Home Assistant running on an RPI4 with the DuckDNS add-on for almost two years without any problems. Since yesterday, the add-on has been transmitting a wrong public IP address to DuckDNS and of course the system can no longer be reached via it.

My real IP and the wrong IP are both from the Vodafone address pool. I am now wondering where the add-on actually gets the wrong IP from.
Has anyone had this before or does anyone know where the add-on gets the IP from.

In order to narrow down the problem, I have already inserted another SD card with an older image from January, here again this one wrong IP. It doesn’t seem to be the RPI.

But where does the add-on get the wrong IP from?

Has your ISP just enabled CGNAT?

The easiest way to tell is to look up the IP address that DuckDNS is getting and see if it is a non routable private address.


So no, most likely not. Sorry for not reading your post more thoroughly.

Officially, my ISP has not switched to CGNAT. But after looking again, the problem could be related to the ISP.
My actual public IP has changed in the meantime, but the wrong IP is always The host name is
This wrong entry can only be found on DuckDNS, on other websites that determine the IP always the correct IP is displayed

So, I had deactivated the DuckDNS add-on the last few days because of the error. I re-enabled it this morning and it seems to be working again now, for whatever reason …