Duckdns addon

I’m trying to access HA remotely through duckdns.

Have set up duckdns domain and my IP is showing correctly there.

Have installed duckdns addon and have set up port forwarding on my TP-link router.

When accessing HA on my local network, I now need to use https and I get a security certificate warning as expected, so that bit is working.

However, I cannot access HA remotely when off my home network, using I just get a timeout.

I’m unsure how to troubleshoot this, but suspect that the issue may be with my port forwarding.

This is what I have set up:

I would guess that, if this was set up and working correctly, I should now just be able to test it by typing in my current IP address: https://xx.xx.xx.xx:8123/ and get the HA login page? This just gives me a timeout. So does this mean the problem is with my port forwarding? I just need to know where to start from to try and resolve this.

give a try like this: https://xx.xx.xx.xx without port as HTTPS would default to 443.

what you are doing on your router is actually, all incoming requests to external_ip:443 to be forwarded internal_ip:8123

https://external_ip is using 443 by default.

1 Like

Same result without the port number unfortunately - times out

So my public IP address (which duckdns shows) is different from my IPV4 address which I can find in my router settings. What’s that about?

If your WAN side IP address on the router is not the one external systems think you are then your carrier is probably NATing you. Bit of a pain as it can break a lot of things.

@siwilson . Thanks. Does that mean I’m stuffed? Is there any workaround?

Not really. Does your ISP offer a staticIP option?

First, can you confirm that the ISP is doing a NAT on your connectiion?

I’m using Utility Warehouse (piggybacks EE) mobile 4G router for my broadband. From what I have read, they use CGNAT. I notice that my IP address seems to change regularly, even though my connection has not been off.

Have sent a ticket in to UW to ask if they can give me a public or static IP. I’m not holding my breath though as it’s a pretty no frills service (£18pm for unlimited data), and a piggyback network.

A friend of mine uses UW on the back of EE and they definitely do CGNAT. It’s a royal pain as it messes with her VOIP service.

Sorry, you’re SOL on that unless you can get a static IP.

@siwilson it’s as I feared. I think there is a cloud service you can use for HA, but not worth it for the amount of times I need remote access.

Openreach have been promising us cable broadband for the last 5 years. A couple of months ago they actually put cables in to the outside of the building. Now they just need to connect them to the main network. EE 4G has been pretty unreliable, so will be happy to switch when we can.

I have used Nabu Casa for a year or so now and it works very well for me. Apart from solving a problem, the subscription is also giving back to the HA team. IMO it’s a small price to pay.