DuckDNS and letsencrypt?

So i’m completely confused on how to get this working. Do I need to be running both letsencrypt and duckdns or just DuckDNS? Also, I’ve tried every tutorial on getting this working and it fails every time for various reasons. The “Official” documentation also does not work.

Does someone have a legitimate way to get this working on

When I follow the official docs and copy the provided code into DuckDNS add-on I get this error:

Missing option keyfile in root for dictionary value @ data['options']. Got {'lets_encrypt': {'accept_terms': True}, 'token': 'blah blah blah', 'domains': ['']}

And when I add this code to my config file it throws all kinds of errors.

Again copied right the DuckDNS docs and modified to include my relevant info:

  ssl_certificate: /ssl/fullchain.pem
  ssl_key: /ssl/privkey.pem

Nothing in the DuckDNS documentation says I need to set up letsemcrypt. But I did any way and I still get the same errors.

Any help would be greatly appreciated


Hey @yesimwilliam,

went through this yesterday successfully with DuckDNS only. Letsencrypt addon seems to be affected by the currently blocked method of retireving a certificate.

The only difference to my configuration I see is the base_url where I configured exactly the same as given in the DuckDNS addon, so “” without “https://” and without a port.

So I have figured out that I don’t need letsencypt. I also have done the same thing you did but I get the same errors like always.
The new thing is I get this error now when I start DDNS service.

starting version 3.2.2
# INFO: Using main config file /data/workdir/config
+ Generating account key...
+ Registering account key with ACME server...
ERROR: Problem connecting to server (post for; curl returned with 52)
Error registering account key. See message above for more information.

It seems to be successfully generating a cert but cannot connect to letsencrypt for some reason. And so when I check my config, of course, it throws all kinds of errors.

So I really don’t know what to do here.


I too am having problems with DuckDNS addon since the problem with Lets Enrypt disabling TLS-SNI.

The fix is to set challenge to http from https but I do not which file to change to make this update any idea?