Duckdns backup with Nginx SSL proxy

I have been using the duckdns add-on with the NginX reverse proxy add-on for some time. This allows me to have unsecure http access on the local Lan and secure https access from the internet. It works well until there is a problem with duckdns like I have been experiencing over the last 24 hours with intermittent connections and Google assistant is really struggling to connect.

I feel I need a backup but the problem is that the NginX SSL proxy will only accept connections on the domain configured. When I had SSL configured in config yaml, I could connect with my external IP or any domain pointing to it (with a warning that the SSL certificate was invalid due to a different domain) but I could still continue and connect.

How can I configure NginX SSL proxy to work the same way?

Ah ok, I had this issue yesterday. So was DDNS down intermittently or something? I thought it was my setup.

There is no mention of anything online but it started yesterday and still happening today. Thanks for confirming you have the same issue. The duckdns name resolves to the correct IP so could still be a HA issue. I am on 98.5, how abou you?

I was on 98.4 (now on 98.5) but I have the exact same setup as you. NGINX for local, DDNS for external. Started yesterday after 3:30 pm EST. Was able to regain some connection by 10:30pm EST. I noticed the issue around 8:30 pm EST.

What’s interesting is that I can access it locally and I used to be able to access it using the domain name inside my network as well. Now the domain name doesn’t work inside my network but it works outside my network. Local has been fine the whole time.

Could be DNS issue. Some servers at are not resolving my duckdns domain, but I am not sure if this is normal.

Now THAT sounds like your ISP did something, obviously not CGNAT but …

Forgot to add that I updated to NginX SSL proxy to v2.3 today and the issue is still happening before and after this update.

i’m also experiencing the same, in the last 24 hours.
i’m using lets Encrypt dehydrated with duckdns.

Mine’s fine in the UK
Where are you lot based (i.e. are you all living in Queens or do you all have the same ISP or … ) ?

Anyone got any ideas on how to set NginX SSL proxy to allow connection by IP or another domain as a back up? It’s not possible to specify 2 domains in the config but maybe a conf file could be configured? Not too bothered about a certificate warning, at least we could get in. Don’t want to open a non SSL port.

I’m using virgin media in the UK. It’s still happening now. Have to try several times to get Google homes to turn on lights.

What version of HA are you on?

You don’t need another domain, just go to your router and find your wan address and use that.
The only reason we use the domain is a) if your isp changes your ip address b) it’s easier to remenber than or whatever
You’re only buggered if your isp does a swapsy

The latest … Just checking … 0.98.5
I saw the post about the nginx update and went to do that
First ddns use after that toooooook aaaaaaaagggggeeeees but then it probably had to do a full handshake with ddns AFTER HA decided to poll ddns so that ddns could get the correct ip
Was a snap subsequently, no issues at all

I’m with (let’s not) talktalk (cheap and not very cheerful)

This doesn’t work with the NginX SSL proxy for me unless I specify my IP as the domain in the settings for the proxy instead of the duckdns address. It refuses the connection.

Can you confirm you are using the SSL proxy?

Exactly the same issue here. Google Assistant (and the Google home app too) struggling. Local control fine when routed locally and then intermittent when it route it over my external data connection. Thought it was my ISP doing something stupid, but I’m on Hyperoptic in London, UK and it seems to be across them all. Seems duckdns are having issues.

I also vad various other subdomain aliases all pointing to my duckdns address and they all are up and down like a yo-yo too. Have the same problem with some random DNS not being able to locate my duckdns address on the address too.

Suppose I can’t really complain - duckdns is free!

1 Like

I’m not complaining either, I would just like another way into my home assistant when the duckdns domain isn’t working.

I wasn’t having a dig at you! :slight_smile:

Agreed. I’m not aware of any other free ddns services though. Be happy to be enlightened of course!

I think with the standard yaml SSL config you can just use your external IP or any other dyndns, you will just get a certificate error which you can continue past but this doesn’t work for the SSL proxy. You must connect with the domain of the certificate. I would like to still connect as per the standard config.

I use the proxy so things can connect without SSL on the local Lan.

So this seems like a duckdns issue then. I’ve found ways around it personally by setting up the iOS app to use local ip when connected to home network.

Maybe it’s time to invest in a different free DNS