DuckDNS configuration

I tried to use DuckDNS addon in Hass.oi.

  1. My addon config is:
    “lets_encrypt”: {
    “accept_terms”: true,
    “certfile”: “fullchain.pem”,
    “keyfile”: “privkey.pem”
    “token”: “xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx”,
    “domains”: [
    “seconds”: 300
  2. And i uncomment http section in configuration.yaml:
    ssl_certificate: /ssl/fullchain.pem
    ssl_key: /ssl/privkey.pem
  3. I make port forwarding for 8123 port
    I copy in adress line my browser. And I see: “could’t connect”
    If i typing only i’m redirected to the web interface of my router.
    Please help me!!!

What if you type in your browser?

By the way, you do not need to store secret information in your configuration.

I try but nothing changed((

Which works with your internal ip address? http://[ip address]:8123 or https://[ip address]:8123?
If the second one works, a certificate error is normal and expected.

Https works with internal ip, http not work

It is good https works. That indicates the DuckDNS addon is configured correctly.

Port Forwarding on your router would appear to be the issue.

On your computer, if you type nslookup do you get an ip address returned? If not that could be an issue too, but not too likely.

It returned ip address of my router - And next my external ip

It should show your external ip address.

It returned my external ip

Try a different browser? Sometimes Chrome’s caching behavior gets in the way.

Some routers do not support HAIRPIN NAT, so you may not be able to get to it.

I try it in Opera browser too, still not work. I check port 8123 in, it displayed what port 8123 is opened