DuckDNS Domain only accessible when connecting to same network. Help?

Hi there,

like i said on the title, i think i successfully installed and configured DuckDNS. I can access through my domain, but, let say using my phone, and i turned off the wifi, I wont be able to access the domain again. Any idea to fix this?

Im running latest on rbp 3b+

What exactly does this mean?
If you mean you can access on your LAN but not from outside it, have you forwarded port 8123 from your router to the hass machine? Make sure you have set a solid password in hass first.

yes, thats what i meant. so since my computer are connected to the same network as the raspberry pi, i can access HA from my duckdns domain no problem. but when i try to access HA from my phone using 4G, it just says connection time out.

i forwarded 443 to 8123 on the ip.

Why? 443 is completely unrelated.

i folllowed a guide that said to uninstall duckdns from add on store,

forward port 80 to 80
forward port 443 to 443

reinstall duckdns, configure, start service and wait for the log to complete all the cert and stuff,
once its done, go back to port forwarding,

delete port 80 to 80
change port 443 to 8123 internal.

and restart home assistant.

what should i do differently?

I only had to forward my port 8123 to 8123…and it worked fine. Did you get your SSL certificates…? Check in the SSL directory for Samba…you may have to add that in the samba config.

yea i read somewhere that u can do it with forwarding 8123 to 8123, but from what i read, that means u need to set ur config.yaml file like https://urdomain.duckdns:8123 and access to home assistant with that exact domain with the port number, where as if doing it with forwarding 443 to 8123, u dont need to put the port number on the end and access it with just the domain itself

are those infos wrong?

LOL i tried it ur way, with the port and it works instantly, thank you soo much!

1 Like