DuckDNS + Google assistant latency issues

I’ve configured DuckDNS and the Google assistant integration a couple of month ago and it run mostly fine since then.

The last couple of days when I try to send a command through the assistant I often get " [name of my test app] is not available at the moment " no matter what device I’m trying to reach (if it was a problem reaching one or more devices the assistant says that that specific sensor is not available and not the whole integration).

If I repeatedly ask for the same action through the voice command at the end it works.

I think it’s a latency issue since I tried to link the same sensors through other services (like deCONZ is connected to Homey Pro too or some other devices have their own cloud service) using different name for the same device and when I try to command the same device through another service is working everytime…

Is there someone else that is having the same issue?

It’s the first time I’m experiencing that in a couple of month but if it continues like that I think I’ll have to try to use the Nabu Casa service.

Thank you in advance

Google and Alexa (smart speakers) have a timeout to get a reply from corresponding service and it should be around 5 seconds.
Probable causes;

  • home assistant was not accessible when you triggered a command. (availability) this could be because of duckdns or your local internet or home assistant physical server etc.
  • home assistant received and executed the command but was not able to generate a response in timeout. (latency)

I am using duckdns and i haven’t felt any extreme or unexpected latency

1 Like

For that reason I assume it’s an issue with DuckDNS since if I try the same command for a deCONZ device but from Homey (that uses its service) and not from home assistant it always work. So I think that my network is stable.
Home assistant supervisor is installed on a pi4 8gb with an SSD and both CPU and RAM have low usage so I don’t think that is a latency related to the HW or to the number of processes

deCONZ is installed as virtual instance in home assistant and is linked on both one assistant and Homey Pro devices.

Unfortunately I don’t think is a fixable thing if the delay is generated by DuckDNS unless I try to use another service on home assistant like Nabu.

The unfortunate thing is that everything was working fine since a couple of days ago.

You know, there are some other dns solutions other than duckdns out there.

I know but since is working is the best from my experience. Don’t know if the delay can be accentuated from adGuard but I didn’t change any setting since a long time

Yes, seeing behavior too since yesterday… I now enabled local fulfillment for it , hoping the issues are gone now…
It’s not a delay issues because the error is within the 8 seconds…

1 Like

Is there a guide to achieve that?

Yes, it’s on the official documentation page…

But it’s not 100% correct, the java file must be the one below, and als “enable local query” must be ticked…
And also a Name field when setting up

1 Like

Thank you, I’ll try to wait just a bit more then I’ll try to follow this steps to see if it helps :grinning:

Just a little update, the Google integration with DuckDNS was continuing to be unreachable at times, so I switched to the trial version of Nabu Casa .
No issue since then, I’d prefer to run a free and local integration but since we’re using the vocal assistants a lot I’ll have to stick with Nabu Casa I think…

issues with duckdns are gone…
i cancelled my nabucasa subscription, gonna move to a cloudfare domain, costs almost nothing , nicer domain name then that duckdns anyway :slight_smile:

This was my hope as well.

Finally set up local fulfillment myself. Continuing to use duckDNS. Had to switch to swag for nginx/certbot and HA on same docker host to finally get things working. Also using avachi on OpenWRT for mDNS repeating across VLANs.

I did stumble across this graph which allows you to see latency times for cloud vs local fulfillment. Look at the 95th Percentile Fulfillment Latency. Thus far, it seems to be <1 second on local vs up to 6 seconds with cloud!