DuckDNS - issues with LetsEncrypt

When following the instructions here it states to not have a certfile and a keyfile in the addon config, but when I exclude it I get an error stating .I need them…

The only thing you should change are the token and domain entries from the default template.

“lets_encrypt”: {
“accept_terms”: true,
“certfile”: “fullchain.pem”,
“keyfile”: “privkey.pem”
“token”: “my-token-from-the-duckdns-site”,
“domains”: [
“seconds”: 300

I tried that as well… Im guessing the /ssl location should update the the certificates, but nothing is populated…

I also get the following error in the log…

starting version 3.2.2

INFO: Using main config file /data/workdir/config

ERROR: Lock file ‘/data/workdir/lock’ present, aborting.

I have made sure I have the port forwarded properaly

It sounds like something got ‘horqed up’. Try uninstalling the add-on, restarting, then re-installing with the bare minimum of changes. The certs get created by the system.


that appears to work, at least I dont get the error anymore… but there still isnt any files in the /ssl directory…

starting version 3.2.2
Sun Nov 26 20:35:38 CST 2017: KO

Hello, new user for about 2 weeks, I first had Hassbian then re-jigged to Hassio and I much prefer it! This DuckDNS is killing me though, I have everything else set up and have muddled through pretty well I think. My DuckDNS log shows no errors. I had to sign in with https so I know thats working, although in my local network I am aware its normal to get the not secure message. My token is right, syntax is right, formatting, etc,…but I can not connect to, have tried with :8123 suffix and my ports are open, have checked with a pc utility and its confirmed. Any idea why I can not connect from the outside? I also opened the port in windows firewall.

Hi guys, I have this problem that recurs cyclically every month. When the error occurs the duckdns add-on crashes. I reinstall it and it works for a month. Then it freezes again. Will there be a definitive solution?