DuckDNS - It's not just me - it's you!

You can always use a Nabu Casa subscription for 5 bucks a month.

Thank you very much for your advice.

I did register with nabu casa and after correcting the url i was typing it worked. I even went outside of my town and tried to connect it did.

I can connect to HA and view my environment. HA does not send me notifications (it did not do this before).
all is almost good.

However i do not see how nabu casa will let my daughter connect to my NAS remotely. Am i missing something?

Thank you

This will not be possible with Nabu Casa. For accessing a NAS remotely I’d rather use a VPN than something like DuckDNS.

This has nothing to to with Nabu Casa or VPN or some other connection to your home net!
For notifications a server from Google or Apple (or maybe another one) is used.
You don’t have to have a direct connection from the Home Assistant Companion App to your Home Assiastnt Server!

thank you for responding

just for your information I tried to ping duckdns through windows terminal and it gave me a time out error. This in my opinion is an issue with duckdns and is the core issue.

Could your issue be related to this?

Thank you for taking the time to respond

i am foobar. I have no such thing as adguard or the such I am just trying to use baby steps to achieve my goals (this is a massive learning curve for me).

Havin been frustrated with duckdns i tried no-ip same result. (btw the are both gifing me the same IP address
Asus support tell me that the router (asus rt acv87u ) is configured correctly go figure!

I do not know what i am missing

With both No-IP and DuckDNS you still need to configure port forwarding on the RT-AC87U to forward external connections on port 8123 to your HA instance. Nabu Casa negates having to do that; your HA registers itself with Nabu Case web server so you can connect to HA using that convoluted URL and the traffic is routed through Nabu Casa without having to open port(s) on the router/firewall and having your system exposed to attack/infiltration.

For pinging your public IP from external, whether via the bare IP address or a DNS lookup via DuckDNS/No-IP, you need to enable Respond Ping Request from WAN in Firewall - General; most firewalls have that disabled by default to prevent a ping-of-death flood attack by those who have nothing better to do with their time.

For remote access to the NAS on your LAN, use the PPTP VPN on the RT-AC87U.

Thank you so much for your reply

I tried Nabu Casa and yes i get to home assistant effortlessly and i guess alexa. Since my last communication I managed to get no-ip to work.

I forward the port i assigned for home assistant 8123 and plex 32400 with some struggle but with success nun the less.

furthermore i can connect via the IP or via the domain name.

I do have a vpn on my router but it is currently not active (i only use it to watch canadian and uk tv which is not often) and my rt ac87u has pptp activated.

Once again thank you for your help

hello all

as i was unsuccessful to activate duckdns on my HA supervised. I reverted to no-ip. and it works flawlessly fro my remote when i am away or from a pc from my friends house… brilliant

I would have a questions:
1 can i use the let’s encrypt statements and configuration made for duckdns in no-ip ]

thank you

I’ve followed the instructions in Mutt’s post #24, but it won’t work for me.
Whenever I try to navigate to I get “400: Bad Request”

A couple of details that may be relevant:
-I’m running the HomeAssistant server on a VirtualBox VM on an Ubuntu machine.
-My router’s port forwarding page asks me to fill in some fields that haven’t been covered in any of the comments that I can find, such as “source zone” “destination zone” and “Source IP” (this one isn’t required, so I’ve left it blank).
-The only add-ons I have running in HomeAssistant are DuckDNS, NGINX, and File Editor, am I missing something?

I’m sorry but I’ve left the forum.
You are correct that the above thread will no longer help you.
There are a number of contributing factors : -

  • The devs are no longer supporting duckdns
  • The project gets financial support from Nabu casa (so you pay $5 per month to get the same)
  • You’d need to set up a vpn method to achieve the same

There does not seem to be any suport for such so any individuals requiring such (you and me) can just go whistle.
I fully expect this post to be flagged and removed, but at least you will receive it.
I review updates and install where I can but fully expect to get to a point where I will have to freeze updates and remain in a stagnant environment to maintain the systems I currently can live with.
Sorry to be so bleak but updates on the issues with duckdns have been outstanding for about 4 months with no evidence of corrective action.

1 Like

The “devs” also provide a Tailscale vpn addon.

But yeah, if you have network issues you cannot resolve, and that you don’t want to pay for have them fixed for you, it must be their fault, obviously.

Damn for real am I understanding this correctly? We are basically SOL for using the method describes in post 23? I’m not willing to pay $5 a month to Nabu Casa, especially when this used to work flawlessly.

No idea what he’s talking about… ddns works fine and it’s still an official addon.

It isn’t working for me either…

400: bad request? Thats all I’m able to get.

Check your HA log, then do a search on the forum regarding the proxy error you likely have.

Sorry, I have seen some replies and feel I must clarify : -

As Petro Points out DuckDNS still functions correctly (This is not directly an issue for the Devs)
The problem is that ‘Certain Spammers’ used adresses from within the AWS (read DuckDNS as AWS provide space for same) range.
The response by ‘some’ (not all, which is why it’s spotty) Service Providers, is to block a larger range than was strictly necessary.
The result of this is that to ‘some’ users (depending on your ISP) can no longer get DDNS to work even though they have been using it sucessfully for a number of years and did not change any config.
Tinkerer has suggested simply using another DNS service but information on setting that up is a bit sparse.
I’ve not seen any threads on anyone trying to resolve this for the common user, which is why I made (probably unkindly) the flippant remake about Nabu Casa.
To help the most people I think a Thread on alternatives should be started.
Or (longer term) a replacement (for the DuckDNS addon) should be provided (I know this is a lot of work) but allowing users to pick from ‘say’ half a dozen DNS services.
I don’t know the best solution, I’m merely making suggestions - But saying there is nothing wrong and blaming the users all the time is not helpful to anyone and contributes to the obfuscation.
I would suggest that this thread be locked until resolution and then unlocked, simply to point to said resolution before closing permanently.

I don’t see a point in locking this. Duck DNS works for the majority of users. This is an issue that you have with your ISP.

If this is true, please stop saying things like this then:

Because that is a flat out lie.

This is an issue you should take up with your ISP and you should not be focusing your anger onto this community or the developers. No one owes you anything, community or dev. This is a specific issue with you and your ISP.

Why is it the development teams job to do this? DuckDNS works fine and it’s free. This is what community addons and community integrations are for. Home assistant provides multiple options to connect to dns services. The official one they provide is DuckDNS. If that doesn’t work for you, then it’s your job to find something that does, not the devleopers.

You can use the dnsip integration to work with any other free dns service alongside letsencrypt.

Here’s a list of other DNS’s that home assistant works with

1 Like