DuckDNS, local access ok but with 'not secure' warning

I have configured DuckDNS addon for my HA configuration.
Local and external access are working.
But for the local access with https://[local_ip]:8123, I get a certificate warning, not secure connection…
Any idea what can be the problem ?

It’s because the SSL certificate is issued for the duckdns domain. Once you use the IP again, your browser sees that the certificate is not for the IP address used and gives an error. Just use the duckdns domain if you want to access HA via your browser.

If desired, you can change your configuration with the Nginx addon: see: Home Assistant + Nginx: Unencrypted Local Traffic

ok thanls for the quick answer.
It makes sense.

But is it the normal way to work with HA to use the external domain when I’m connected on my wifi ?

I personally do use the external domain also on my local network.

There are other configurations possible though.
You might want to look at the Nginx addon and this article: Home Assistant + Nginx: Unencrypted Local Traffic

I’ve just checked, and the use of external domain is not working on my computer through local network

you sure you added https and not http in the URL? What error do you get?

yes it https, but it’s working on my smartphone with 4G connection for example

in fact with the computer I get a HA page, but showing ‘unable to connect with Home Assistant’

That’s odd. Does the same thing happen in a different browser on wifi? Maybe it’s a cache thing.

I’ve cleared the cache.
Still the same.
I get a page ‘loading data’ for few seconds, and then "unable to connect’.

It’s still working fine on my phone using the app and on web browser.

Can it be link with this part of HA config:

(In parallel i’m reading the post about Nginx.)

Yes I guess so, what happens if you add http instead of https in the Local adress (Résau local)? Or just remove it?

BTW, you probably should remove the “:8123” after your duckdns adress. SSL goes usually via port 443, or did you configured it that way?

i’ve removed the config above, still the same thing.

For the :8123, I understood it has to be configred that way.
I’ve open this port in the box

You can’t open port 443 and redirect that to port 8123 on 192.168.1.xx (home assistant address) on your router?

I’m configuring NGINX it makes sense when I read the post.

Ok good, I think you should be able to get it working without Nginx as well though.

No luck…
I’ve installed NGINX, and open port 443 for HTTPS to my HA IP.

Now I can still access HA from my smartphone, but still not from my computer on local network using the domain adress…

But now if I acces through the IP with HTTP it is working without warning on certificate

And now I have a new problem… :slight_smile: Using my usual webbrowser, I can no longer access some addon like ‘file editor’ or ‘studio core server’. I get a “401: unauthorized”
But it is working on Edge for example…

I fix the 401 problem by a deep clean of chrome and restart

I guess my problem is my computer. It’s from my company, there may be some protection which block me. I will try with another computer.

[EDIT] Nope still not working using https://[mydomain]

Hi Emile, did you change the addresses within the Home Assistant settings? In the screenshot you posted:

So without the port number in the external URL