Duckdns "missing required option 'token'"

Hi everyone,

I am trying to setup duckdns, but without much succes. I have created a domain on duckdns and copied that domain and token to the configuration of the duckdns addon, but when I try to save it I get the following error:

Failed to save add-on configuration, Missing required option 'token' in Duck DNS (core_duckdns). Got {'lets_encrypt': {'accept_terms': False, 'certfile': 'fullchain.pem', 'keyfile': 'privkey.pem'}, 'token': None, 'domains': [None], 'aliases': [], 'seconds': 300}

It seems as if it can’t find the token and domein, but I don’t understand why, since I copied them both to the configuration. Does anyone know what is going wrong here, and more importantly how can I fix it?


  accept_terms: true
  certfile: fullchain.pem
  keyfile: privkey.pem
token: (my token)
aliases: []
seconds: 300
1 Like

The indentation for the token line looks incorrect? I think you named the token line incorrectly.

This forum is not a substitute for reading the (fine) documentation.

# Example configuration.yaml entry
  access_token: YOUR_ACCESS_TOKEN

From Duck DNS - Home Assistant

Thanks for your reply.

The configuration I shared however isn’t my configuration.yaml file but the configuration section of the add-on itself. I have also already tried to add the same lines of code that you mentioned to the configuration.yaml file, but also without any succes.

I have read the documentation section of the add-on very carefully and my configuration looks exactly the same as the example that is given in de documentation. But even though it is exactly the same as the example it still doesn’t work, how is that possible?

Your addon config looks ok. The token should be of the following format (note, no quotes):

token: nnnnnnnn-xxxx-yyyy-zzzz-aaaaaaaaaaaa

Where each of the letters above represent hexadecimal numerals (0-9 or a-f).

Thanks for your reply.

My token is in that exact format so that shouldn’t be the problem either.

Have you forwarded the required ports in your router?

This is the only similar issue I could find (with resolution):

I have forwarded the correct ports in my router and I tried the resolution mentioned in the github issue that you mentioned but still no luck.

It is also rather strange that it doesn’t matter what I put in the configuration of the add on, I always get the same error. I even tried leaving it completely empty (just to see if I got the same error, cause it obviously wouldn’t work) and I still got the same error. So it seems as if the configuration section just doesn’t get read by the add on.

The problem turned out to be the fact that I wasn’t running the newest version of home assistant. Now that I have updated home assistant it works fine.

1 Like

The problem i had was correctable in the yaml config in the setup screen. (settings/aplications/duckdns/config then on the three dots on the upper right and select the YAML )
then change aliases: {} in aliases:
then click save en start duckdns.