DuckDNS not starting at all

The last few monts the Duckdns addon has been unable to start.
Hence, when the external ip changes, I am unable to reach my off-grid HASS.

The add on does not start on reeboot, and will not start when I press the start button.

The config should be OK:

  "lets_encrypt": {
    "accept_terms": true,
    "certfile": "fullchain.pem",
    "keyfile": "privkey.pem"
  "token": "my-duckdns-token",
  "domains": [
  "seconds": 300

PS. I have commited out the:
ssl_certificate: /ssl/fullchain.pem
ssl_key: /ssl/privkey.pem

As I had issues with lets encryp at the time I installed Duckdns.

Please help!

I foud this in the system log:

9-09-29 15:55:24 ERROR (SyncWorker_2) [hassio.docker] Can't create container from addon_core_duckdns: 409 Client Error: Conflict ("Conflict. The container name "/addon_core_duckdns" is already in use by container "42d2f87d9c7b49b6190467a44e7a39bb73f6d0ba3cd6c324bcbfb926506d0d83". You have to remove (or rename) that container to be able to reuse that name.")

How do I remove a container?

Copy your config, remove the add on then add it back with your copied config.

Thanks allready tried that.
Have uninstalled Duckdns addon, restarted, reinstalled with old config.
Still getting the same error in system log and the addon wont start.

Just checking, you are aware that you no longer need the lets encrypt add on for duckdns ?
It installs just the subset it needs during setup.
I would clear every duckdns trace, every letsencrypt trace, all http: statements from your config and start again with a more recent guide. I would of course recommend … “my own” :blush: :rofl:
DuckDNS it’s not me

Install portainer addon and check and see if there is another duckdns addon… you can remove them via portainer. Also delete the one you can see as you did before. You will probably find you have a second copy of the addon.

Thanks! It worked.

1 Like