DuckDNS with IPv6 only

Hello everbody,

I use Home Assistant on my RasPi with My ISP uses IPv4 and IPv6 in Dual Stack. I already figured out how to connect using IPv6 and this works fine for me. Now i have the problem that the DuckDNS always updates both adresses: IPv4 and IPv6. This results in some errors when using Google Home (Google Assistant) to controll switches, etc.
Google Home only works, when I delete the IPv4 entry from DuckDNS.

Is it possible to configure the DuckDNS Addon in a way, that it only updates the IPv6, but not the IPv4 Adress?

Thank you

Hi did manage to solve the problem ?

I found out, that the problem was the Dual Stack lite connection. I upgraded my internet contract, so that I now have a full Dual Stack connection. So now I have no shared IPv4 but a dedicated adress.

@Fubi95, can you explain how you configured HA and DuckDNS to use IPv6?
I am struggling to do that and did not find a solution yet.

My ISP said that they provide IPv6 addressing, therefore I have no option to set up port forwarding on my router. Indeed, there is no such option.
Still I can locally connect to HA only via https://homeassistant.local:8123/ - getting an SSL error, DuckDNS domain does not work for me, nor ipv4 address I used previously. Of course, remote connection does not work either.

Details on my installation:

  • HA core-2021.4.6
  • VM via VirtualBox
  • Network adapter in bridge mode
  • on DuckDNS website only my external IPv6 filled out, no IPv4
  • DuckDNS add-on up and running and configured in line with the documentation