Dyson fan in Google Assistant


I have a Dyson pure cool configured in home assistant. It’s working properly in the web interface, but when I expose it to Google home, It always appears active. If I say “activate fan” it works, and also power off, but in the graphic interface appears as ON and I cannot activate it. The state is fine in HA.

Also, there is no option to set the speed. Can any of this issues being fixed?


i have exact the same problem using template fan, it appears as off in HA interface and also in Alexa but google always say is active, i noticed that today, and i just searched and I found you comment.

i think it was working before.

option to change the speed fan appears only in mi nest hub smart display, mobile and tables doesn’t show that, i think is by design

I have the same problem with my xiaomi fan 2s. Anyone found a solution yet?