Easiest steps to run a script on from Android app

I have several script that I need to run from Android app. So, I open HA app, select Menu, select Configuration, select Automation and Scenes, select Scripts icon, then only two letters of script name are visible, so I have to open the script to make sure that it is the right one and then run it. is there an easier way?

I tried to use Tiles but the list of script in Tiles does not match the scripts that I have in HA. Some of the scripts shown in Tiles are the ones I have deleted long ago. I uninstalled and reinstalled the HA app, but no luck.

So, how to make the process of running a script less painful?


Why don’t you create some buttons with any custom names and call respective script services as script.script_id.

I might be overlooking the issue, am i?

Go to Developer Tools > States and look at all your scripts. These are the actual scripts you have which the app can see.

Very correct…!!! The script names in Developer Tools is what I am seeing in Tiles but they are not matching the script names that I have created. I have checked in YAML mode also. The script name shown in developer tools is not there anywhere. So, where is HA getting this name from? How to sync these names?


When you create a script the name is not the same as the entity ID so find the correct matching one in states tab and that is the one you want. The name you set is actually the friendly name attribute.

Thanks again. I just edited the name in scripts.yaml file and now all is good. The script names in Developer Tools match what I see in Scripts. Created Tiles and they seem to be working fine. Thanks for the pointer to Developer Tools. I never thought of looking there.

Although Tiles has worked, I have added script to buttons also and it works. Thanks for the idea. Apparently, HA has more than one way to solve a problem. The community support is great…!!