Easy start of Home Assistant on Docker... but no devices found

So I’m not a Docker expert and find the networking configuration confusing so I’m guessing I’ve got something I need to tweak there. I installed the Home Assistant container on my OpenWRT PI CM3 installation and it was a breeze for me to install, start and connect to the web interface on 8123. However during the startup when it searched for devices it just hung there. I refreshed and was able to skip over the network search… but now I have no devices. When I try to add a device that’s supported it says it’s not able to connect.

I connected to the container console and when I run ifconfig I see eth0 configured to the internet side of the router and eth1 configured to the network side. I’m thinking I don’t want eth0 available to docker at all… if I figure out how to customize the containers network to only allow the internal network will that solve the device connection issue?

Still don’t have the auto finder working but I’m now able to see and connect to devices manually so that’s good enough.

Use host networking else discovery not work

Post how you created the container

1 Like

I used the Rpi walkthrough (basically a single docker command… super easy) which does use the host network.

  --name homeassistant \
  --privileged \
  --restart=unless-stopped \
  -v /PATH_TO_YOUR_CONFIG:/config \
  --network=host \

(sorry the above is incorrect but the forum insists on turning the text into a hyperlink)

There are a few differences... I'm running OpenWrt (rather than Rasbian) on a dual GigE board (CM4 Pi). I had some issues at first with manual device add but discovered that it was working fine but I made some mistakes at first that were causing it to fail to add known devices, but as I doublechecked things I figured out how to get them added. 

It would have been a bit easier to have them all added automatically but it really didn't take that long so not that big a deal (I don't have THAT many automation devices yet).

I assume you didn’t literally type that. You do know you have to actually put your own data in for your timezone and the directory you want to put your config in?

Wouldn’t have worked if I’d not entered the correct tz.

The autodiscover did start working after a while (days or maybe a week or so later). By then I’d configured all the devices I wanted but it found a bunch of things I’d not really thought to connect to it.