Echo Devices (Alexa) as Media Player - Testers Needed

New PR submitted that should resolve lxml. Finally got myself a hassio install for testing.

@phantomdarkness: I added a dependency requirement for simplejson that may resolve this for you if you’re on hassio. If you’re not, there’s probably a little more logging before that point that will help zero in.

   - platform: alexa
     email: [email protected]
     password: amazon_pass

Thanks! How do I know for sure what etc to use?

Now i’m just getting a timeout reading image error, I think the amazon emailing a verification code is my problem.

It should be where you typically would log in to Amazon. I’ve found that if your’e out of region, you may get less functionality out of your devices (i.e., TTS may not be available).

Same issues as posted above with 8.0 on 75.2. Log full of errors and TTS not working. Rolled back to 74.0 and 8.0 version works perfectly.

Do I have to turn off 2FA in order for this to work?

I think I see what you mean, when I try I get a verbal error from alexa saying “sorry text to speech can only be called with the media player alexa tts service”

That specific error is because this media_player cannot play media (e.g., mp3s) from other sources. Amazon has not opened up the API to send media directly to the echo yet. You get the specific message about TTS because the most common use case is if you use the TTS option in the media_player details UI, it will create a mp3 file and pipe it to the alexa media_player.

The TTS I was referring to was using the service media_player.alexa_tts

Do you know if they are gonna open the api? Would mean more options!

Using 0.8 I can now finally login and set the component up - but its only picking up one media player, and its an alexa app.

Anyway to force discovery of devices?

I am getting this same error

2018-08-07 12:04:00 ERROR (MainThread) [homeassistant.requirements] Not initializing media_player.alexa because could not install requirement lxml==4.2.3
2018-08-07 12:04:00 ERROR (MainThread) [homeassistant.setup] Unable to prepare setup for platform media_player.alexa: Could not install all requirements.

I switched lxml for html parser and now it works … Now on to TTS … is there a nice guide for how to get this to work?

I’m not on Hassio, i’m using hassbian.

Could it be my 2fa? Or does the captcha get around that?

To fix the library issues with lxml and beautifulsoup4 you need to modify the requirements. The requirements document within are older than the one already installed in newest ha 0.75.2

So i changed to:

REQUIREMENTS = [‘beautifulsoup4==4.6.1’, ‘lxml==4.2.4’]

and all works fine.


I added the exttra files and added the automation and finally added the two entries to my media group, however I don’t get it up as a card in my front end, is there any other extra steps needed to make this work?

I changed the requirements as you suggested and it works like a charm.

I’m running Hassio 0.75.2 on Raspberry Pi and Alexa 0.8 now with modified REQUIREMENTS.

Thanks a lot

The latest .81 fixed my issues with HASSOS!!!
Well done guys!

Has anyone been able to speak a value for a sensor?

After trying out .81 i get this:

2018-08-07 17:50:28 ERROR (SyncWorker_6) [custom_components.media_player.alexa] Error loading pickled cookie to /config/alexa_media.pickle: An exception of type FileNotFoundError occurred. Arguments: (2, 'No such file or directory')

working great now, thanks once again, and now love that i dont have to do that captcha thing any more